Hello guys, i have a bug with mesh colors

I imported from blender train doors model, and mesh colors are different but same. Someone know how to fix that?

  • Do you have a TextureID in your MeshPart properties? If so then delete that.
  • Are some of your faces Inverted?
  • Are you using the ShowBothSides (I can’t remember if that’s the exact name) property of your MeshPart? If so you should ONLY use that for flat meshes like leaves or paper. If you do use it because the mesh has inverted faces then you’ll get lighting issues like this.
  • When you have the Mesh open in Blender select all the faces, go to the Mesh tab, select Normals, and choose Reset normals. This may align the corners ‘normal’ orientation to show lighting differences more realistically.
  • I don`t have mesh texture
  • How can I find out?
  • I have it turned on, because the mesh is visible at half, if you do not turn it on.
  • I know about this thing in blender, and when i activate “face orientation”, all faces are blue

I know exactly the problem, inside of blender select everything and go to mesh and then go to normals and recalculate the outside!


How to recalculate the outside?


You have to go into blender and select the whole mesh and I’m pretty sure you have to be in object mode, on the top corner go to mesh and then normals then recalc outside


As some people mentioned, a possible issue causing this is inverted faces. If faces are inverted and you have DoubleSided checked it can cause some ugly shading and discoloration. I have already made a similar post about fixing inverted faces:


Okay, but all faces is in face orientation is blue, why my mesh colors in bugged?

1 Like

Do you have duplicate faces? If so select the entire mesh and click m (to merge) and select By Distance . Is DoubleSided on in Roblox? If so you don’t need it since your faces are blue (this would usually be used for objects that use 1 face but are needed to be see from both sides). If those don’t work then I’m stumped. It would be easier to remodel it.


What mode it is?
object mode, or else?

1 Like

I found it, but blender says, 0 vertices removed, it ok?

1 Like

I didn’t say to recalculate Normals, I said Reset Normals. This realigns Vertices to point in the right direction for shading purposes.

Try changing the Merge settings and Merging again. I think the default measurement is .0001. I usually set it to something like .005.

If you turn off the ShowBothSides and the Mesh is correctly built you should see it correctly.

If you’re face orientation is blue like you stated then don’t listen anymore to people saying to recalculate normals.

Another issue might be that you have internal Faces that go between Edges inside the Mesh. Have a look for that. If so in your Edit mode go to the Select tab and there should be a tool there name remove internal faces or something like that. Internal faces cause a real mess with shading.

I know when this bug, after i click mirror Y

I don`t know how to fix mirror

If you’d like you can PM me the file (just the door) and I can have a look at it.

try using the mirror modifier instead of mirror in blender for the mesh.

You can use the Symmetrize tool for this as well. Symmetrize — Blender Manual

81-765doornew.fbx (729.9 KB)

Wow, just wow…
Did you get this as a 3D model or did you create this yourself?

This is waaaaay to detailed. I selected all the faces and clicked the Triangulate faces tool (because that is the way Roblox renders meshes) and you have 31,692 tris in just this tiny model.

There are some great tools in the Mesh Tab:
Mesh > Normals > Reset Vectors - will clean up your twisted faces.
Mesh > Clean up > Merge by distance - gets rid of extra vertices modeled at the same location.

I then just selected all the faces in your model and used the Merge by distance tool with the increment set to .005. It reduced it from 15932 vertices to 5511 vertices which is a decrease of 10421 vertices!!!
This means there are now only 10,961 faces (tris) instead of 31,692.

You just have way too much detail in your curves and faces in this model. If your computer tries to render this multiple times (think how many doors your train has) you are going to start lagging.

Have a look at the flat outer faces I selected here (the front and rear faces of the outside of the door pillars). You have 224 tris on each of the pillars faces that could be rendered with just 2 tris! That’s 112 times as many as you need there.

The curves of your multiple door sections (window frame and other components) have 22 segments for a 90 degree curve. At the scale you are working with you probably only need 6 segments in each curve. This calculates to 15 degrees/segment in an area which is probably only be about .4 studs across. That’s more than enough since you have about 24 of just these curves.
24 curves * 22 segments * 2 tris per segment = 1056 tris
With 6 segments you get:
24 curves * 6 segments * 2 tris = 288 tris

I create this myself)))Thank you

1 Like