Help! The Chat Won't Work On My Game!

Hey there!

I am have been having some issues with my chat in my game, and the issue is specific to this game, no other game that I have made so far.

I have tried everything I can think of, but nothing seems to work.

The only thing I have in my game that I didn’t build myself, are these pets, 300+ Free Simulator Pets!(and these have 0 scripts), and a couple scripts for checking errors, Error tracking with Sentry on Roblox, and I don’t think this is the issue.

I had some plugins, and there is a possibility they injected something, but I don’t know which ones, if any, but you can check my plugin inventory if you want.!/plugins

I made a post a bit ago on this topic this, Why won't chat work for my game?, and the best that we can get so far is the chat frame won’t show up for some reason.

You can check this if you need more info

So anyway, I would really like to figure this out, because this is going to be literally game changing if I can’t figure this out.


  1. Does anyone see a problem like I forgot to turn something on or something like that?
  2. Do you see any plugins in my inventory that could potentially be an issue?
  3. What is the best way to find plugin injections?
  4. If I can’t figure this out, who should I contact at roblox support(if that is feasible)?
1 Like

Did you make your chat resizable? Sometimes the chat resize button spawns off screen.

Where do I find out if it is or not? To my knowledge I didn’t but I should check, thanks!

You can look in the ChatSettings ModuleScript:
In the script you can change the WindowResizable variable.

1 Like

Ok I found a bunch of this stuff on size, but I don’t see anything about resizable

module.MinimumWindowSize =, 0, 0.25, 0)
module.MaximumWindowSize =, 0, 1, 0) -- if you change this to be greater than full screen size, weird things start to happen with size/position bounds checking.
module.DefaultWindowPosition =, 0, 0, 0)
local extraOffset = (7 * 2) + (5 * 2) -- Extra chatbar vertical offset
module.DefaultWindowSizePhone =, 0, 0.5, extraOffset)
module.DefaultWindowSizeTablet =, 0, 0.3, extraOffset)
module.DefaultWindowSizeDesktop =, 0, 0.25, extraOffset)

Edit oh wait no I found it, it is false, should I try changing that

module.WindowDraggable = false

module.WindowResizable = false

module.ShowChannelsBar = false

module.GamepadNavigationEnabled = false

module.AllowMeCommand = false -- Me Command will only be effective when this set to true

module.ShowUserOwnFilteredMessage = true

Try changing one of these values by 1 or 2:

1 Like

Ok, but how can I change it if it only appears when I start playing? Thanks for you help by the way!

When you change the value in the script that is what the size will be when you play the game.

1 Like

Ok, I changed it(but only when I was playing it), but it didn’t do anything…

But there is nothing there for me to change? For me at least it doesn’t show up anywhere in the explorer, unless I am actually playing it.

Sorry I might just not be understanding
Screenshot 2021-06-07 104633

Oh I see now. You have to copy the folder when you’re in game and then paste it into the Chat service when you’re not in game.

1 Like

Ok I tried that, I didn’t work but should I try a few more different numbers on the ones you said to change? Just to be sure?

Yeah, you can change some of the window size settings and you could try turning window resizable on and off.

1 Like

Ok I tried some different combinations, and, no success, it is almost like something is blocking it… Would this make a difference?

module.ScreenGuiDisplayOrder = 6

When you click play, look in your player’s PlayerGui folder and look for the chat gui. See if anything’s wrong with it.

1 Like

Um it isn’t even there! No wonder…Screenshot 2021-06-07 110915

@camomileex0 said something about this, but I don’t know how in the world it wouldn’t be there besides some mysterious plugin injection…

If you put free models in your game you might want to check those. You can search “Script” in the Explorer search bar to look for any weird scripts.

Ok I did, and the only ones are the ones I put in the topic

Well then, it’s definitely a plugin then. You might want to go through your plugins and check if they have script injection on.

It looks like it’s been disabled in the Studio chat settings.

We can’t see your inventory, go to settings and make it visible to the public.

1 Like