Horizontal scroll w/ mouse wheel breaks camera zoom and instead tilts camera

Would also like to add that utilizing the horizontal scroll also breaks ROBLOX Studio vertical scrolling. I think there’s a roblox horizontal scroll issue everywhere.

2 Likes

This just began happening today for me, and is a considerable hindrance on my ability to play my own game.

8 Likes

For me it happens Vertically, this happens rarely and this bug is really ticking

EDIT : It’s pretty much already been found out that when you hold “Ctrl” and then “scroll your mouse wheel”, you can trigger it easy.
It’s sort of easy to commit this accidentally, there is no fix but to Rejoin the game Manually

10 Likes

It doesnt seem fixed on some Windows computer

17 Likes

Holding Left Cntrl/Alt + Scrolling forces this behaviour. It pretty much breaks zoom and you have to rejoin server to fix it. Is there a temporary fix for this at the moment that I’m not aware of.

7 Likes

I’ve made a separate bug report for similar, possibly related issues involving pressing ctrl:

5 Likes

This bug makes it impossible to play on games like Blockate, because in that game, you hit control to access the build menu; But the issue is control activates this bug for me. Roblox, please fix this.

7 Likes

Never mind, but it still is pretty annoying. Blockate changed their keybind

4 Likes

I tried to play a Roblox game today and it’s still not really possible because of this. It’s awful user experience when I’m stuck in a close-up camera zoom

7 Likes

Bumping this because this bug is back again. I’m a bit annoyed because it makes playing games annoying because you have to hold down control. I am on a desktop and not a laptop too. I have a Logitech G303 if that’s relevant, so no side scroll.

7 Likes

I think this might actually be a problem with a change to the camera script. Games that fork the camera script and use an older version don’t have this problem (zooming works consistently on some games only).

4 Likes

I’m once again running into this issue while using a Logitech G502 wired gaming mouse on Windows 10. It only seems to be an issue if I have to press control. Very frustrating that this wasn’t looked into before being released.

4 Likes

I’m using a Corsair Ironclaw and just encountered this issue after messing around the camera settings via the in-game control menu (Esc)

3 Likes

I’ve uncovered some more into this problem. In Roblox Studio:

  • A function bound to Enum.UserInputType.MouseWheel via ContextActionService is not triggerred at all by scrolling my mouse, only by scrolling my trackpad.
  • The InputChanged event of UserInputService is only triggered by scrolling my trackpad, scrolling my mouse doesn’t trigger the event.

In comparison to this, scrolling triggers InputChanged via UserInputService in-game, but doesn’t trigger ContextActionService binding to Enum.UserInputType.MouseWheel

However, scrolling my mouse does “trigger” and zoom the camera in the following games, which suggests there’s some variation depending on the how the input is handled:

Roblox is the only software which I’m having this problem on, and the problem is limited to 90% of game’s I’ve played, and Studio. Please look into it, I didn’t buy an expensive mouse for it to only work properly on 99% of software… the 1% being solely Roblox.

6 Likes

bump – still happening even with a cheap mouse

6 Likes

bump once again because i have a razer basilisk and it’s been happening to me too since last week.

Bump, happens to me with a Logitech mouse, albiet rarely because I go out of my way to not do it
edit: didn’t mean this to be a reply to that specific bump but whatever

1 Like

I have made a temporarily fix for this, incase devs want to fix the issue right away.
Place the PlayerModule in StarterPlayer and replace the BaseCamera module with this.
BaseCamera.rbxm (18.4 KB)

3 Likes

How did you implement the fix? Would be interesting to know if this has anything to do with the weird ContextActionService stuff on my end.

I have removed the horizontal scroll completely, now whenever you try to use the horizontal scroll, you will scroll in / out instead.