How do I remove these weird lights?

How do I remove these lights in the corner without having to set brightness to 0 or making parts gigantic?

This is my settings.

3 Likes

Make your walls thicker. Other than that there really isn’t a solution:

10 Likes

I tested this out myself, and I found that unchecking the Global shadows box seems to fix the issue I think you are having. If I am interpreting your problem correctly, then this should fix the issue you are having.

2 Likes

That does fix it but I like to keep shadow.

I wouldn’t untick the global shadows options because then assets look sharper and if you were to go outside and view your house it would look quite weird.

4 Likes

I don’t see how unchecking global shadows makes things look weird. Literally the only thing that global shadows does is well, remove shadows. Some players seek it out, others do not.

1 Like

It makes a lot of stuff not look right by removing environment shadows (maybe just ones caused by the sun, but I’m not entirely sure).

For example, here's GlobalShadows on

And here's GlobalShadows off

In response to @Vayz though, making walls thicker is really the only option here. Notice that this bug is less prominent on the Voxel lighting system (make sure you change - it looks a lot nicer with the right settings).

6 Likes

I understand that and all, but you must realize that it all depends on what your task or what you want to create.

I don’t think it’s worth sacrificing good environment shadows in a game in order to fix a bug. Making the walls thicker usually works fine.

Something works different for everyone. Its better to give the person more than one option, right?

If he adds lights to the house and a exterior environment as I said in my reply. Assets will look darker and things will look weird.
@Vayz Do you have any additional stuff like Sun Rays?

3 Likes

You could try altering ClockTime with the GeographicLatitude.

Other than that, you may just need to change your exposurecompensation or your brightness to solve this issue or wait until Phase 2 to come out to see if there’s a patch to the issue.

Other than that, @XAXA explained it simply well.

3 Likes

The issue with making my walls thicker is that with my current lighting settings i will have to make walls atleast 6 in Z size to completely remove those lights that would make houses look really big and ugly.

I do but it does not affect lights in anyway.

Bloom does if you have neon materials.

1 Like

I’ll try to tinker with my lighting settings and see which one is best for me.

1 Like

I do use bloom but i am not using any neon.

How intense is your bloom? Could you show me the settings? And what parts do you have? Could you also show me the workspace?

1 Like

Here. They don’t make much difference rn.

SunRays
3
Bloom
4

and i am using mostly SmoothPlastic.

Hmmm, i’m gonna test your issue too. Let’s see what happens.

1 Like