How do you make objects have no reflections? Is it impossible?

I’m winging a waves system, but there’s one jarring issue.

With the correct lighting (Brightness set to 0, Ambience set to pure white) I can somewhat get the illusion.

However, with the lighting settings I actually want for the game…

This is how it looks from above.

And this is how it looks with the jarring lighting:

I set the meshes to have a fabric material to mitigate the annoying reflectiveness as much as possible, but it’s no good. I need something that completely ignores lighting. Same for large flat planes like the ocean surface having no lighting.


If you make the waves using ImageHandleAdornments instead of physical parts that will solve your problem, since they’re completely flat shaded.

1 Like

They need to be meshes, not billboard GUI’s

Unless this is something else

ImageHandleAdornments are 3D world content that you can position at any location in the 3D space using their CFrame property, they have nothing to do with BillboardGuis.

See this post: Need purely visual parts for plugins in Studio without affecting collisions and undo history


I had no idea this existed, might have to take a look at this

Not surprising given few people do. One of the most underused parts of the current Lua API.


What about the ocean surface? What should I use for the large flat plane? Same thing?

Yeah. Since it’s just a visual object you can use one BoxHandleAdornment and set the size as large as you want, there’s no size restriction.

1 Like

Am i able to use meshes instead of boxes/ flat images?

Unfortunately not. Box / Cone / Cylinder / Line / Image is all there is.

Not quite what I’m looking for then sadly

If Roblox released a material like Neon, except it’s just “flat shading” and can have its lighting properties inhereted into meshes, I feel like lots of people would make great use out of that

Do you use Meshes for making wave?

For like waves? If so here’s how. Just change it in the properties of terrain. You can also change the color so you can see the waves a little better. :smiley:

you should be able to do this effect by manually setting the normals of the mesh to face upward. This will give it the same specular highlight as the flat plain underneath, as long as you don’t tilt the mesh’s rotation.

try this (for blender 2.8):

  • select every face in edit mode
  • head into mesh > normals > point to target
  • hit M to move the norrmals to mouse, then click anywhere to bring up the manual settings
  • check Align, set every target to 0
  • set either X, Y, or Z (depends on the initial rotation of the mesh) to like 1000, until the mesh looks “fullbright”

it helps if you have the setting to see normals represented as purple lines too, since you’ll know you did it right if all of the normals are facing straight up

if it works, might be worth trying to set just the normals of the edge of the mesh, that way the raised, foamy parts of the wave still have some highlights


I got to this part, can’t find this option

Hey, pro-tip: read OP’s post a little more closely before trying to scrap together a quick reply. You clearly put in effort into your reply, creating an example place and then taking a screenshot of it, but if you had read the post, you would know that what you are addressing is not what OP is asking, saving you your time and effort.

are you running blender 2.8? I mention this because this feature is only available in 2.8 and up. this is what my window looks like.
if it was just that my explanation was unclear, here’s a video showcasing the feature. Blender 2.8 Normal Editing - YouTube

1 Like

Downloading it now, oops

1 Like

Seems like I still get the issue, but I may just be doing it wrong

Waves1redoneagain.obj (3.4 KB)

^ here’s the .obj for it

EDIT: I got it now- I just need to modify the flat plane now


Ty :smiley:


A lot better now :smiley:

(This is with extreme lighting test)