I can't publish over my existing published place

  • Detailed description of bug;

Part of my workflow is to keep my rbxl saved locally; I open it in studio and then publish over the existing place.

Repro steps for me:
File->Open From File…
Choose my rbxl
Choose Publish to Roblox To…
Choose overwrite existing game
Navigate to and choose the one I want to overwrite
It loads in and I notice that it’s not the one I just tried to overwrite it with

(How to post a Bug Report - #13 by Roblox) / [log files]
(Didn’t crash, so I’m not posting dumps.)


Additional information:
I also cannot publish over the place with a different place loaded from Roblox; the difference there is although it says ‘Dungeon Life was published successfully’ it doesn’t automatically switch places in Studio and when I open the place manually it is the same as it ever was.

It seems to be something about the places in the game I’m trying to overwrite (Dungeon Life Development Zone - Roblox) - I was able to publish over a different game’s existing place just fine.

1 Like

Did you click the file and then click “Publish to roblox”? It might have been that. Or you just saved the game and didn’t publish?

1 Like

I’ve been having this exact issue as well. I’ve tried every option (save to, save to as, publish to, publish to roblox to) and they all just open the target game without modification.

Edit - I narrowed down the issue, at least for me. I believe this is a conflict between Team Create (and how it saves your place) and the publishing feature. The publishing happens parallel to when studio automatically opens (and saves) the place you wish to overwrite.

Solution - Disable Team Create & Overwrite


Would you be interested in some critical feedback on your post?

1 Like

Seems like this has been fixed. Or has stopped reproducing for me anyway.

1 Like

This is still an issue. Normally wouldn’t be such a biggie, but considering how often Team Create goes off (it’s that unreliable now) this is a big bother and delay when trying to develop.

Places with team create on have to have team create turned off in order to be able to overwrite those places. Are there any plans for this bug?

1 Like

i have the same problem right now, when i try to save my place, it doesn"t want to .

For recent issues please see: