Unable to start team test or publish game (Internal Server Error: 500)

All of a sudden Studio refuses to let us publish or team test one of our games - it just gives the error message Server Save Failure: HTTP (500): Internal Server Error.

Steps to reproduce:

  • Press “Publish to Roblox”

Expected results: The game should be published

Actual results: We get an error message in the console: Server Publish Failure: HTTP (500): Internal Server Error

Affected game: [Tasty Kingdom] Ninja Rush - Roblox

Team Test works for other games.

The “studio log file” does not contain any more information, relevant rows:

1598278831.30664,1280,6 Saving to Roblox…
1598278833.36328,2030,6 Error: Server Save Failure: HTTP (500): Internal Server Error
1598278833.38086,429c,6 Project Kyoto save failed.




Having the same problems when publishing and saving my group game.


1 Like

Same, I can commit change but can’t publish at all.

It seems like none of my script commits saved. You should back up your place in a file while this is happening, as when I reopened studio on my game it did not save any script changes.

Edit: The changes appear during the studio session, but do not ultimately save. Had I not done constant back ups and I’d had lost all progress.


Can confirm this. Publishing doesn’t work for me either. Tried to save the place to a file and save/publish that insead, but there’s no sign of ‘updating’.

1 Like

Same is happening to me.

I pushed to file luckily.

Damnit! The one time I make a good update!

1 Like

im also getting this error when trying to import objects image

Can confirm. Got disconnected due to a short power outage, I came back and my UI work is gone. Came back on and I’m getting HTTP 500 errors as well.

Furthermore, assets cannot be uploaded, can’t view my already uploaded decals etc either.

This is a more major outage than team create.
I have a non-team create place which I just made, it is failing to load assets, my universe entities and it is just a baseplate with a script.

I created a place by using ‘publish to’ on a team create game. I don’t have permissions to my own game.


Can confirm this is happening to me as well when I am trying to update my game.

Doesn’t even save the game, nor can I download a copy of the game for some reason. (meaning I am stuck with the update but I can’t close studio ((it doesn’t save)))


Tried to overwrite a place, same issue as most people are having.


1 Like

Same happens to me, if you need to go offline like me, I would recommend to save it locally on your computer. By going to “File” > “Download as Copy”.
And when it’s fixed you just open the copy and upload it to that game back.


I’m getting an error 500 when trying to upload animations…

Thanks for the report, our teams are looking into it.


This issue should be resolving now. Thanks again for the report and for your patience.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.