I just loss all the scripts of my game help me

So I wanted to test my game on mobile, to do so I had to commit all my scripts, but it didn’t work and I got an error message, so I went to the draft to delete all the files. All my scripts are now empty, as are the recovery places in the game. I’ve lost 3 months’ worth of scripts and have no idea how to restore them.

All my scripts are empty

please tell me there is a way to restore them, i’m afraid


Did you upload the game or this local file? If you uploaded, you can try to restore the previous version.


Restoring the place to previous version already and the scripts are still empty, they just have disappear. Even from local save i did myself some days ago

Did you run the game through Roblox? Do the scripts work in this case or does their behavior remain empty?

1 Like

All the script are now completly empty, i just have load of “Hello World”. I sincerely hope roblox will be able to reverse this

Of course I understand that this may be risky for you, but give me the entire file of your game and I will check if the script context is empty for me, perhaps the problem is in the studio. (This is only at your discretion, I do not insist)

For those who are trying to help in the future: for me the file was also empty. It looks like the studio overwrote the entire file after damaging it.

Deleting the drafts is not the answer to fixing an error message that randomly appears. If you delete the drafts, there is nothing left of it and you need to commit to the scripts to save them.

Common issues around committing is often tied to conflicting code.

Yes, but how can it delete scripts from all older versions of the game, from all saves made? With no way, apparently, of restoring them. 4000 lines of code just gone.

maybe your roblox studio is corrupt? have you tried on a different computer

Absolutely correct, try downloading an older version of your game from the Creator Dashboard on a different machine. Roblox Studio likes to do these things from time to time, and your code is more likely than not still there.

I don’t exactly understand how to download a previous version from the creator dashboard, i haven’t the option

1 Like

That’s very weird. I have the option to download all my versions in the history. What’s more, you have the option to revert to a published version, which does not make sense.

Are you certain you are looking at your place’s version history?

1 Like

Yea :confused:

I looked this up, try the solutions in this thread:

I tried but unfortunatly everything is still empty. I guess i’m going to rescript everything.

Maybe you could have browser plugins affecting your page? Could you try removing them, or try a different chromium browser that you don’t normally use?

i haven’t plugins, except adblock in chrome. And i’ve tried with two others browser. I tried to contact a few admins yesterday to see if they can restore me an older version with all the scripts but haven’t received answer yet. So i’m just tried to redo everything but that’s a pain, over 3500 lines, a lot of maths, make me tired.

Do you have another device on hand?

1 Like

yes i just tried with my other computer as well, to restore version/open my previous locals files. But everything is empty, i mean the scripts

By local files you mean local recovery autosaves?

1 Like