Inverse Kinematics Crashes Roblox Studio

Hello,
I use bandicam.
Also, I have tried many of the steps you have sent, excluding the least plausible and most difficult and outlandish one (Resetting my microsoft profile??)

I agree, that is a bit far. I’m sure we can fix it, I’ll be back in 5 minutes to help you further.

Okay, I’m back sorry about that, I’ll send the video in a few minutes, I just have to set up the recording software.

While I’m doing that I noticed you said that it didn’t have anything to do with your plugins (in your previous post). I’m not saying I don’t trust you, but if you could, please send me a screenshot of all your current active plugins just so I can look into them and make sure they are by trusted users.

Hello,

Hello, thanks for that.

Here’s the video:

Just a follow up from your plugins.

I noticed that it’s most likely your plugins, here’s how to fix it

Disable all plugins you haven’t used in the last 2 days, ones that you haven’t used in 1 month +, remove them.

The animation editor plugin is from 2014, and it’s broken so it could be interfering with studio features, as well as other plugins.

My suggestion is to remove all your plugins and try, then enable the ones you need.

Thanks,
Void

Hello,
I have disabled all my plugins and I am still encountering this issues.

Hello,

Once you have disabled all plugins, restart your studio, open a blank baseplate and test it there.

Hello,

Hello, thanks for that.

Doing some research, your not the only one experiencing this issue. Roblox said they have fixed it. May I ask you to try on the browser and instead create a new place through studio, if you can.

Hello,
What do you mean by “try on browser”? Also, I already created a new place through studio.

I noticed that what your using roblox on doesn’t seem to be the browser, it looks like an app. This probably doesn’t contribute to the issue so ignore that last bit.

Hello,
I’m using stylus, an extension that allows you to change the theme of the roblox website. This is in no way related to roblox as all because 1. I coded the styles myself 2. I have had these styles for over half a year now

Okay, not a problem.

I do feel this is a bug report so we might have to see what Roblox say on this thread. I’m not sure what to do really as there’s nothing much I can do. It’s very weird that it’s happening just for you but works for all of us.

Can you try check if your browser is up to date, I don’t think this could be it (just to see)

This was from official roblox documentation. Please try anyways, I know it says Internet Explorer by you never know.

To Minimize Future Problems

Always ensure that all programs are closed on your computer before installing or updating Roblox. For Windows, ensure that Internet Explorer is up to date with the latest version.

Source: https://en.help.roblox.com/hc/en-us/articles/203552894-General-Roblox-Studio-Issues

Also, would you mind letting me know what your roblox studio version is?

image

it should be this, you can check by hitting File → Studio Settings then search for “version”, it should be under Diagnostics.

1 Like

Hello,
image

1 Like

Alright, seems to be a studio bug. Sorry I couldn’t help further, we will have to see what Roblox say. You can use a separate animator for now if you wish, I recommend this one here:

Have a great day,
Void

1 Like

Hello,

Important UPDATE:

Alright, I believe I have discovered the culprit of this issue.


Adaptive timestepping.
This new beta feature apparently crashes the IK in the animation editor. The moment I turned it off and restarted studio it stopped crashing.

9 Likes