Keyboard shortcuts not working in Studio

Frequently, shortcut keys do not work in Studio when a script has the focus. Specifically, when I am editing a script and then use the shortcut key F7 to launch a server, nothing happens. If I then switch focus to the output frame and press F7, Studio then launches a server. The same is true for the shortcut key Ctrl-Shift-F. I am unable to provide details about the conditions that cause this, but it comes and goes. For instance, one time the shortcut key will work then later it will not work and later still it will work again.

This is also true when the 3D world view has focus. My terminology may be off here. I’m referring to the actual view of the world that opens by default when opening a place.

What OS are you on? I just tried this out and both of those shortcuts seem to work fine.

Thanks for looking into this. I am on Windows 7 Ultimate. Not sure if it matters, but I am not using the ribbon bar.

Additionally, the shortcut key Alt-P to publish to Roblox will occasionally not publish and will instead enter a ‘p’ character in the body of the script. This may or may not be related. I haven’t seen this occur very recently, but figured I’d add it in case it helps track down the problem.

1 Like

It’s not tied to specific shortcuts / specific widgets like the script editor. It’s an issue with keybinds where they all stop working altogether irregularly and erratically. If it helps narrow down the issue, right clicking on anything to bring up the context menu (regardless if you close it immediately after or not) fixes the problem.

Thanks for verifying I’m not alone in this predicament. :wink:

Based on your advice, I tried using the context menu key followed by escape (to close the context menu), then the shortcut key again and it works (keeping hands on the keyboard at all times).

If I open a place, add a script and try to use F7 and Ctrl+Shift+F, they both seem to work fine. Is there something I’m missing?

Yes. It doesn’t happen reliably – only after erratic periods of time. I’ll usually notice when I try to duplicate something and my camera moves to the right instead (thinking I pressed D instead of Ctrl+D) and sometimes when I try to use Ctrl+Q (custom-set keybind) to select all children and it doesn’t work.

Additional info: It happens after I save (ctrl-s) and the mouse pointer momentarily turns into the spinning blue “busy” icon.

If I press Ctrl-S and the mouse pointer doesn’t change, the shortcuts remain functional.

This may have something to do with saving in rbxlx format. Can anyone else experiencing this confirm?

The Boulder cannot confirm

Steps to reproduce:

  1. Open Roblox Studio
  2. Click the Baseplate Template
  3. Ctrl-S to open the save dialog
  4. Change the save type to Roblox XML Place Files (*.rbxlx)
  5. Click the Save button to save the file to disc
  6. Click ServerScriptService in the Explorer pane
  7. Double click Script in the Basic Objects pane to add a script to the ServerScriptService. The script opens in the editor.
  8. Press Down arrow to navigate to the first blank line in the script. Then type the following:
    local i = 10
  9. Press Ctrl-S to save
  10. Press F7 to start a server. Nothing happens.

These are my studio settings:

Edit:
I also renamed my plugins folder to plugins.old and InstalledPlugins to InstalledPlugins.old and restarted studio to ensure that no plugins were interfering.

Thanks for the repro! Just so you’re aware, System Menu is deprecated, so any issues relating specifically to it will be ignored. However, I can repro this as well with some minor changes to the steps in Ribbon Bar, so I’ll add this to our bug list!

1 Like

I have a similar issue, but instead of that, my scroll, f to zoom and maybe some other stuff I don’t know about, just doesn’t work…
it did a few days ago

1 Like

I am having this issue right now as well, zooming in by scrolling is no longer working and I can’t seem to find/ focus on parts using f

edit: this only seems to happen in certain games, not all of them.

edit 2: I’ve done a update and re-download of roblox studio and it’s still not working :c

edit 3: when playtesting, I can’t esc to stop. the only way to get out of playtesting is to quit studio entirely

I am also periodically having this issue, but it’s not just zooming by scrolling and focusing, its all my keybinds, they randomly disappear (even default ones) and I have to reload studio to get this back. It usually happens if I leave studio running AFK for like an hour, then come back. like 3 times out of 10 it will happen and it’s pretty annoying, sometimes effecting my workflow.

I might try a reinstall, but I have a lot of settings and other stuff that I would have to write down before it happens, so it’s not preferable.

(edit: when I say all of them I mean all the shortcut ones, I can still move, and also rotate the camera with my mouse, click stuff, all the basics, but anything else like focusing parts, opening servers, F5 to playtest, all other stuff just doesn’t work.)

1 Like

It’s a bit of a bump, but it’s 100% the same issue.

I’ve been having this issue for the past week or two.
I can have 2 studios open, and in one I can scroll and press F to Zoom To, but in the other studio none of those things work.

Still happening, I can confirm :confused:

2 Likes

Its happing to me now with the zoom to and del!
I try rebooting my pc and everything I think roblox studio is just a mess it will work one day.