Mesh Splitting Enabled for Uploading Multi-Mesh Files

#64

Text Filtering Update!

Thanks for all the support and feedback! After reviewing the feedback you all provided, we made a major improvement to the way our text filtering works in Studio for asset importing. As many of you know, we have a strict text filter in place across the platform in order to keep Roblox safe and friendly. That being said, we want to remove as many blockers as possible for our developers so that we can keep empowering you to create. In order to do this, we have implemented a text filter bypass for asset import.

How does this work?

  • Anytime you upload an asset into Studio, we will run the name through the text filter.
  • If it is flagged as inappropriate, instead of rejecting the file, we will fork the asset name from the asset alias and allow the file to be brought into Studio.
  • If this occurs, you will see a warning message in the import window saying “Asset name on website has been moderated.” This means that we have automatically renamed the discoverable asset name on roblox.com.
  • For meshes, it will be renamed to Meshes/meshPart and for images, it will be renamed to Images/images.
  • In Studio, your Game Explorer will show your original unfiltered file name (as the asset alias).
  • You can still change the name of your asset on the website using the Configure option

Hopefully this helps and let us know if you have any further questions.

43 Likes

#65

This is great, thanks!

1 Like

#66

This will help me a lot with my future projects. Thanks!

1 Like

#67

Thank you, this will be a huge help to me when I’m importing a rocket tomorrow

1 Like

#68

Ah! Thank you so much for this! This will really help me a whole lot better! I appreciate it!

2 Likes

#69

This is a very nice feature for the convenience of others. I don’t use Blender or meshes, but I already see the others’ perspectives right now.

0 Likes

#70

Thanks x)

;-;

1 Like

#71

Make sure all your objects share the same location point, that’s the only thing I can think of that would do that.

0 Likes

#72

THANKS!!! I was looking exactly for this, since my mountains had incorrect collisions.

0 Likes

#73

I can’t seem to get mesh splitting to work with any .obj files. .fbx files work fine however. Any way to fix this?

0 Likes

#74

No idea, I’ve also tried to parent meshes into an Empty in blender but I don’t think that’s how it works, I don’t even understand it.

Can someone please explain to me how I can make mesh splitting work?

0 Likes

#75

You don’t parent them – you keep the objects you want to split as top level

0 Likes

#76

YES!! This is going to save me HOURS of time!! Thank you!!!

0 Likes

#77

It doesn’t work for me. The option is set to not import files as a single mesh but it still joins them together Screenshot_362 Screenshot_363

1 Like

#78

This is amazing, I am glad this was added. No more big meshes! :grin:

1 Like

#79

Hey, quick update and maybe a help for others,

I discovered that the meshes not being split was caused because I didn’t check a specific box that allowed me to export .OBJ files as groups instead of single meshes.

Open up blender and load in your meshes

Once you’re ready to export (in this case as .OBJ files) you will need to check this box in the export options (left-side of the export screen and scroll down until you see this:)
checkboxes

Make sure the “Objects as OBJ objects” box is unchecked and the “Objects as OBJ groups” box is checked

then export it and import it to Roblox Studio, if the method was correct, the mesh name should have a “Split from X.obj” subtitle on the import screen.
( example )

6 Likes

#80

Update: You can now import up to 200 assets at a time. If you are importing meshes with several mesh files in them, the 200 limit applies to the cumulative number of files after they have all been split.

7 Likes

#81

That’s insane, thank you so much for the time and effort you guys put into making mesh importing so much more streamlined! :heart:

0 Likes