Minimap Render [RoRenderV3]

It is already fully done. Just waiting until @reteach posts it after some bug testing and possibly a few benchmarks comparing V2 with V3.

2 Likes

Quick question, how much would it take for the plugin to render a 16384x400x16384 large terrain map?

I cannot really predict. You can test it out once it is released, but it should definitely be many times faster than V2.

A major bottleneck is 500 Http requests per minute, otherwise it would have been possible for the render to be instantaneous depending on the speed of the CPU.

That can be bypassed with a FFlag :P, would love to have a version that would allow more than 500 requests.

1 Like

Which FFlag. That is definitely interesting. Can make renders super fast.

Massive update to v4. Huge shoutout to @StrategicPlayZ for making this happen. The main post has been updated guides and description of the application. Let us know what your experiences are with the new version!

6 Likes

Very cool, just tried v3. Worked awesome on the first try. Glad to see this getting updated still.

This took 11 min on a i7 9700KF @ 4.6ghz 8 core. 7k x 12k image.
image

The only thing I could think of to improve is to send data while rendering, as it seems to pause rendering to send pixels. Could speed this up 20% maybe as the CPU isn’t getting full utilization 100% of the time. The orange arrow is pointing to the ro render application using 10% CPU avg, seems like a lot? Could reducing Rorender app CPU overhead improve studio render performance?

Great work as always,
Widgeon

5 Likes

The CPU and disk usage is due to a few inefficiencies in the application which will be fixed in future updates.

Sending data while rendering is going to make a difference and we have plans on including that in future updates as well. It is not included in this one because without it Studio may stay unresponsive at all times making the PauseRender attribute useless. A solution to this is to have application tell Studio in response to SendData request to pause the render, and when want to unpause, doing it from Studio directly. This will require a few changes though so it will take some time.

1 Like

This keeps happening (I’m rendering a baseplate with some parts on it, with V3)

Send the exact configurations of the settings. (Right click the settings and save to file)
Also send the map.

It’s auto configured, and it’s a baseplate with 2 objects, you can try this yourself

Render looks great and was fast. I’m trying to use this with Plum’s minimap.

That tool requires you to write four values down: “Pixel Size X”, “Pixel Size Z/Y”, “Pixels/Stud”, and “Center Position”.

I could figure out Center Position by using the Position of Draggers.Center. However, I’m not sure how to find the previous values. Screenshots show as if the plugin used to display those values.

Is it possible to find these values or do I need to use an older version of RoRender?

1 Like

It is working for me without any problems. You need to send a file which reproduces this error. Without reproducing the error somehow I cannot fix it properly. No one else has reported this issue yet.

The main values you need to configure Plum’s minimap are center position and the size of the map.

You can find center position by position of the Center part in the Draggers folder. The size can be found by checking the Scale property of the Mesh object inside Center part.

Just put these values in the Plum’s minimap config and it should work.

1 Like

Something doesn’t seem to be working for me. It seems to be off by around 75 studs. I tried swapping the X and Y of Map.size in case that was the other way around, but it still seems off for whatever reason. I’m not quite sure why. Any other ways I can try and debug this?

I don’t know how Plum’s minimap works internally, it could be an issue with that. It is not possible for the MapSize and MapCenter to be wrong, as they are taken directly from properties.

If the MapSize is a Vector2, then when you paste in the size from Mesh.Scale, remove the middle value.

That’s what I did for the latter. Also tried flipping it the other way (Z, X). No avail. I’ll mess around withit more tomorrow.

Hey, how do you get this RoRenderV3 to work? I keep getting an HTTP 404 (Not Found) when I try it.

It happens in Line 61 in the Server Script in ServerScriptService.

You are probably using V2’s plugin. Remove that and download plugin linked in the post.

404

But, I really got the 404. Can you send your RoRender that works right now? When’s the last time you tried it just incase your just not updated on how it is?