"Modern Studio" (new docking behavior) has various issues

@ElephantMesh @Hauber_RBLX @DarkPixlz

I found out what causes the layout of the Draft window to be lost.
I opened a bug report:

4 Likes

From my perspective of never having disabled Team Create, I can tell you that it’s worse than broken:
It’s flaky. From the beginning of this new disaster Studio redesign, the Drafts window sometimes will
come back to where it was manually docked, and sometimes it will be in that odd location.

(You may find that your solution is really a phantom, as I mentioned, it has always been flaky.
Today I tested the Drafts window location at startup 6 times–Its location failed only on the 6th test.)

BUT, on my setup, the Drafts’ View setting (that I set as visible) is always lost on Studio startup, lost
along with the view setting of the Chat window as well (I always have to manually set them as visible.)

3 Likes

the new studio docking feature just seems like a rushed edit to “modernize” studio. It ended up just making docking widgets and stuff more complex and harder. I prefer the old system much MUCH more than the new current one.

4 Likes

Running a test server with 2+ clients still bricks the viewport:

1 Like

Hi, have you tried to reset your layout?

3 Likes

I have, and the issue still occurs.

1 Like

Issue still occurs to this day

10/11/2022

1 Like

I’m not sure if it’s just me but the latest issue appears to have made the issue worse. Now, about 50% of the time, my viewport gets bricked with a single studio instance open, and while doing a solo 2-player test at least one (usually 2) viewports get bricked essentially 100% of the time.

2 Likes

So, I hadn’t actually been using studio until today; that’s why this is late.

I’m sorry to inform Roblox that they didn’t fix anything, in fact, it’s downright worse.

I used to be able to still use studio after the viewport “broke” and “crashed” but now when it breaks it crashes literally after I updated studio.


This is outrageous and if there isn’t a good fix for this buggy behavior (which might I note, makes development on Roblox nearly universally unfeasible,) there’s gonna have to be an explanation given as to why Roblox has been pushing buggy updates with very little quality assurance testing.

Anyways, some notes:

  • Apparently this is even more of an issue in some cases on Windows 11. I’m on Windows 10, no plans to upgrade any time soon, and it’s already bad enough on here. Can’t imagine this getting worse.
  • I run FPS Unlocker, not sure if that’d cause any issues directly, but it might; can never rule out possibilities.
  • My monitor does not benefit at all (from what I can tell) from the High DPI updates since I’m using standard 1080p (albeit at 144Hz)
  • Still not fixed, kinda furious ngl.
3 Likes

I have heard the issue was worse on Windows 11 as well. What stands out here is that you have a high-resolution monitor with DPI scaling. This bug seems to only occur on devices with this configuration (I have a device that has this issue, but it isn’t the device I use).

However, I have fixed the slowness of studio by upgrading from 21H2 to 22H2 (if there is any).

Multiple FPS unlockers are available for Roblox. Which one do you use? I’ve heard this can cause issues with studio when entering and exiting playtest mode. I don’t use any on my main computer and I don’t have any issue.

1 Like

You would not believe how bad this is with 2 screens. This must be escalated ASAP.

2 Likes

I use the original FPS unlocker, I believe it’s made by “Axstin” on github. (Checked, that’s correct.)

I’ve not had so many issues lately, but I haven’t been using studio that much as it really killed my motivation if I’m being totally honest.

I’d like an update from Roblox Staff asap.

1 Like

Can confirm this to be an issue, I literally opened the ToolBox, dragged it to those things that show up to dock the UI and it told me it needed to be restarted: (It says you guys are investigating the issue)

When I say “those things” I refer to this:
image


Also, sometimes opening ToolBox will make it unsearchable, not sure if this is related to the Docking behavior as well. When you take it out of where it is and move it around the things don’t load either sometimes. (Happens constantly but unexpectedly, I just tried replicating the bug I mentioned in the first picture and it didn’t happen this time, see)


Experienced an issue again: (12/17/2022)
image

I opened ToolBox while in the Script Editor in order to get the SoundId of a sound, but this issue happened which made the ToolBox not work at all and the rendering is all messed up.


Unrelated Issue but Valid: What’s going on with Roblox crashing more than often? Every time I close down a place that I edited for a while, the Roblox Studio app says Not Responding and after a while, I spam the Close X button since it stays like that for minutes. Even that doesn’t fix it until my PC asks me if I want to kill it and so I proceed.

I am using Windows 10 and my pc is 5 Years Old.

3 Likes

Whoa, I thought this was just a GrapeJuice bug that only happened on Linux.
The toolbox & entire docking mechanism is really glitchy.

This is just roblox biting off more that they can chew.

1 Like

It’s disappointing that since October, this issue hasn’t been fixed and the only solution is an extremely bandaided one. When I debug certain features in my game, I have to switch between the Server and Client mode to ensure things are going smoothly. After switching from the server to the client, I get this annoying floating widget that appears that is not closeably and persists after runtime stops.

I have reverted to older versions of Roblox Studio using Roblox Studio Mod Manager and reset my widget layouts twice, but the pesky thing always comes back.

Please, Roblox engineers, I urge you to fix this ongoing issue ASAP as it has become a major disruption to our workflow and development to me and other desperate developers. This is getting ridiculous and as others here have shown frustration, the solution isn’t always to reinstall studio. These bugs are becoming more and more frequent and I display concern for the wellness of the testing of these new features before being pushed to production use. I hope that within the next few patches, I should no longer see my studio glitching and artificating 99 different widgets upon boot.

End of short rant.

3 Likes

I’d like to add on all the issues/concerns I’ve been having. Not sure if they’ve been covered here yet:

  • The toolbox seems to be completely broken. Whenever roblox studio UI loads, the docking completely breaks and it clips over the UI. If manually undocked and redocked, it can break the entire UI, causing the camera tab to clip out and the scripting tabs to not load at all when switched to.

  • About half the times I load any place, the workplace camera tab is clipped out and unusable. This issue persists even if the place is relaunched. The only way to fix it, from my experience, is restarting my PC.

5 Likes

This is the exact same thing that keeps on happening to me aswell. It is absolutely unbelievable that Roblox even thought shipping this update out of Beta was a good idea, considering the state of Roblox Studio right now. There are times where I wake up, decide I want to develop and then lose any and all motivation I had when I open up Studio and experience one of these bugs.

This feature needs to be pushed back into Beta. It’s clear that every “patch” Roblox engineers seem to be making is not doing much to fix the issue at all, and sometimes it ends up as even worse than before. It’s gotten to the point where I don’t even want to develop, because I know I’ll open Studio and I’ll have to deal with whatever way my layout has decided to break.

No, resetting the layout does not work. No, reinstalling does not work. This feature needs to be pushed back into Beta, right now. Roblox, do you value the money your developers make for you? The state of this feature is horrendous, and it’s been going on for what, weeks now? How is this not a critical bug? How has it been so long?

To add on to this post, here’s just one of the various ways my Roblox Studio keeps breaking. Fun, isn’t it? Forgive the light mode, I’ve reinstalled Studio way too many times now.

6 Likes

Let me join… Literally cannot navigate the topbar… They’ll stay there even after stopping the simulation, have to exit and enter studio to solve this!! I have work to deliver, when can we expect a fix to this attrocious update!

2 Likes

Confirming that this issue is still occurring for me as well

2 Likes

Found another issue. When in studio and you try to search keywords or full names of models in your inventory, the search results only show models added to your inventory after a certain date or within 1 page of your most recent additions to your inventory. I cannot find any other models that I have confirmed are in my inventory from earlier dates. They are not on the “page 1” of my inventory anymore so they no longer appear in any search results in the toolbox, but still appear when you scroll down to find them. I have thousands of models in my inventory, and this has been extremely difficult. I have reinstalled studio dozens of times, tried different devices, different networks, troubleshooted to the nth degree, but nothing seems to work. I even made an effort to email tech support at ROBLOX, and I am only getting the usual scripted preset answers on how to troubleshoot using “community help articles”. Those articles have done nothing to fix my issue and provide zero context to my issue. This has become very frustrating. This new studio overhaul has produced a mass amount of bugs that I would have assumed the engineers would have tested for before pushing the overhaul out live to the public…

1 Like