Most assets fail to load

Reproduction Steps
I’m not sure how to reproduce it, because I’m the only one I know experiencing it. It just happens as soon as I load anything in studio or any game.

I’ve tried:
Different devices: Windows 11 desktop, Windows 10 laptop, iphone
Different networks: Wifi, ethernet, mobile data, VPN
Reinstalling, wiping caches/registry, restarting machines, different accounts, different games, different files

Expected Behavior
Game assets to load normally. Even a blank baseplate should still load my character meshes and animations. Animations, images, meshes, solidmodels, textures, etc should all load in a reasonable amount of time.

Actual Behavior
All of the endpoints explode, next to no meshes, sounds, animations, images, even block colors take a second to load.

Another symptom is loading locally saved files into studio automatically crashes studio. This includes hitting new file.

Datastores are loading normally, but that’s about all.

Dev console is filled with the following:
MeshContentProvider failed to process https://assetdelivery.roblox.com/v1/asset?id=5801850180 because Error reading mesh data: unknown version
Failed to load sound rbxassetid://2874697725: error code 46
ContentProvider callback exception: Serializer::loadInstances can’t read header (x2)
SolidModelContentProvider failed to process https://assetdelivery.roblox.com/v1/asset?id=3314959336 because readData error: OK 0 bad 0 fail 1 gcount 0 readsize 32 offset -1 flength -1 freeKB 12867836.000000

Issue Area: Engine
Issue Type: Display
Impact: Very High
Frequency: Often
Date First Experienced: 2022-03-04 14:03:00 (-05:00)
Date Last Experienced: 2022-03-04 00:03:00 (-05:00)

60 Likes

I have it as well, had it the whole day. I know a couple people who have this, and one who does not. Status.roblox.com says it’s all good so that’s weird.

7 Likes

Hello, everyone! Did you attempt to reinstall Studio?

Hey, I seem to have same problem. I tried to reinstall, but nope. Nothing.

3 Likes

Also, to be sure, this issue isn’t about asset loading in toolbox, right?

A lot of content doesn’t load for me.
It’s assetdelivery related.

I think it can also mess up the recently uploaded assets. My mesh can crash the studio on insert and preview can break the UI.

2 Likes

It’s not toolbox assets, it’s also not limited to studio for me, happens in normal games as well. See my post for troubleshooting steps I took.

2 Likes

cc @nightend16 it would be a great UX update for developers if more error info was shared - considering that the issue is with assetdelivery it would be helpful to see an Http error code or any other relevant information other than just “invalid version”. :slightly_smiling_face:

1 Like

Thanks for the info, everyone! It would be very helpful if you could give us full client logs if you can. https://en.help.roblox.com/hc/en-us/articles/360016022492-How-to-Retrieve-Client-Logs

1 Like

I’m getting the same errors also. I thought my account got banned or Roblox had an outage because none of my assets loaded.

1 Like

https://en.help.roblox.com/hc/en-us/articles/360016022492-How-to-Retrieve-Client-Logs Can you send me a log file, please?; If someone else could send one too, I would appreciate it so much

2 Likes

Sure! I’ll dm you it right now.

1 Like

that happens to me too. Not load many sounds, many of the buildings in my game disappear, when I test my game my character does not load correctly, and the output throws weird errors.

1 Like

It’s happening with other games on the site too.

2 Likes

I had the same issue all day, I thought it was just me.

1 Like

Might be worth clearing the C:\Users(Your Windows Username)\AppData\Local\Roblox and tell me if it helps.

4 Likes

I had the same exact problem. Clearing out the local folder fixed it, but then when I went back in-game or Studio, the error came back but to a smaller degree.

2 Likes

Or it will be good to get directory (detailed if possible) listing of these directories:
-AppData\Local\Temp\Roblox
-AppData\Local\Roblox
Also file properties in AppData\Local\Roblox. (right click in on file in windows explorer and see properties).

1 Like

The files in AppData\Local\Temp\Roblox show lots of content provider folders, then at the bottom is a sound folder that was created today. Along with the sound folder is an HTTP folder.

The files in AppData\Local\Roblox show a bunch of folders, like logs, downloads, a cookie file, a server ROBLOX Studio file, versions folder, and other miscellaneous files and folders.

The properties for AppData\Local\Roblox is 1.8 GB on disk and 1.78 GB for size.

1 Like

Uninstalling and re-installing won’t clean the http cache, but it is safe to manually delete (may help):

  • AppData\Local\Temp\Roblox\http
3 Likes