New Animation Curve Editor: Fine Grain Control of Animations

same issue i’m having, seems like they didn’t fix it

Worked fine just yesterday, and a bit later this error happened. The animations work for me, however marker events seem to be broken. Hopefully it’s getting fixed soon.

right now im not using the new curve thing because im not really experienced with it. two problems, first my uppertorso is set as Part0 of a motor6d and my gun’s grip is Part1 of the same motor6d. uppertorso seems to be welded to the humanoidrootpart which looks really bad (it does not move when the character is walking). the noises for my animations rely on the animation markers which don’t work either. my other guns which i’ve uploaded before this update work fine

2 Likes

did you get it to work with an animationcontroller as opposed to a humanoid? because that’s the issue im currently facing

I’m experiencing the same issue as well! I hope they do, this update broke animation editor completely for me, I can’t do anything “advanced” with the animation editor. Outrageous if you ask me

I guess we were just lucky to have it work. They’re working on it currently. Just gotta be a little patient.


Source (scroll down)

1 Like

Hi MinkMink, can you share the assetId for the animation that reports a broken markercurve ?

i can’t pinpoint it, but i do believe it to be these three:
10231900468, 10231879307, 10231969620

Still having trouble with my animation too. The MarkerCurve thing is not working for me either but what is more important to me is the UpperTorso and LowerTorso seeming to not move at all. They look completely stuck with their given orientation. There are no tracks in the animation for the Upper/LowerTorso. The Motor6D Part0 is the UpperTorso and Part1 is the gun grip. I have not had this problem before when animating guns after this update.

Hoping someone can take a look at this since I’m trying to add new guns to my game but cannot animate them if all my animations will just break.

4 Likes

I am also having the issue with MarkerCurves still. Events were triggering fine before a few days ago, but now all animations that include them are causing this error on load:

Invalid character encountered in marker when decoding MarkerCurve. Instance likely corrupted

2 Likes

I tried to make a simple idle tool holding animation, making sure to only add keyframes to the arm connectors.

it’s now messing with the rootpart, lowertorso and uppertorso walk animation, forcing them to CFrame.new(), but I haven’t placed any keyframes for those parts

image

Is it possible that you made it so the animations player applies a default CFrame.new() to “folder parts” that have no curves in them? This is making it impossible for me to layer animations correctly.

5 Likes

This completly broke every animation I have. I no longer can access the normal easing styles making animating impossible, and I no longer can copy paste keyframes without them being blacked out and completly broken / unusuable. Thanks again roblox for completly ruining my project. Never update ever again.

1 Like

Hello,
The Animation Clip Editor will create a new animation if you convert one to curves, so unless you overwrote it, your original animation is safe. This is explained in the pop up window that shows up when you convert your animation.
As explained in this document the easing styles have been removed from curve animations and replaced with a tool that calculates all the keyframes for you.
Can you share more information about the copy/paste issue you are seeing?

2 Likes

Hello, thanks for reporting this issue. We are actively working on a fix.

3 Likes

Animation events finally started working again, however both studio and roblox client freeze/crash if you try to use like 3 different marker events in one animation. Doesn’t matter whether you’ve implemented :GetMarkerReachedSignal or not, still happens if you play the animation. Also importing animations with this feature created prior to markers breaking (like a week ago) crashes the studio as well. The workaround is to manually download your animation from the website and then delete all markers inside the animation track instance and load it.

3 Likes

yup, still doesnt work properly on non-player characters and custom rigs;
https://gyazo.com/afbb1e67484d9aba446ad71ad8567e71

how did this get overlooked in the first place? (its obviously not supposed to tpose)

Small issue with the current version. It doesn’t work with tools in-game. I was fully able to animate this BFG rig and use it in studio, however once I loaded the game, the BFG itself wasnt animated. It does this with both motor6ds and with welds on tools, and I would love for this to be fixed as soon as possible.
image

3 Likes

it has been over a month since the last post, and you still cannot use the animation curves on anything non-humanoid. when is this finally going to get fixed, i’ve been holding out on updates for my game because i can’t revert them to normal animations?

3 Likes

Same, I’m trying to create animations for custom rigs, and they refuse to play. It’s really a shame, because this new curve editor is so easy to use.
I’ve noticed one thing though:

local animation = Instance.new("Animation")
animation.AnimationId = "http://www.roblox.com/asset/?id="..tostring(walkAnimID1)
animation.Parent = game.Workspace
local animationController = petEquipped.AnimationController
local animator = animationController.Animator
local animationTrack = animator:LoadAnimation(animation)
task.wait(1)
animationTrack.Looped = true
print(animationTrack.Length, animationTrack.Looped) --Does print out values
animationTrack:Play()

It appears that the animationTrack does get returned, but it refuses to play. And I’ve tried this with both AnimationControllers and Humanoids, any rig that does not seem to resemble a player character does not run the animation. FYI, it plays fine in the animation editor, but doesn’t play outside of that.

I really hope roblox could fix this sooner, because this is really stalling my development.

2 Likes

Hey @ProfessionalPlayer60 and @minkmink,

This post is an announcement and is not actively monitored. To report issues, please file a proper bug report and follow the instructions here, that would help us a lot!

Thanks :slight_smile: