New Paste Command Options for Faster Workflow

NEW UPDATE 7/14: It’s back! This time without busted your beloved hotkey. The two new commands should now work as intended with no ill side effects.

Roblox has two new commands accessible via the right-mouse context menu:
Paste At Original Location and Paste Into At Original Location

Each of these pastes the selection at the location it occupied when it was copied, as opposed to other objects in the scene. This makes it easy to copy objects directly from one instance of Roblox Studio to another without needing to resort to complex workflows.

All the paste variations have the same behavior, whether collisions are enabled in the ribbon or not.

The two new commands do not have default hotkeys, but you can add them using:
File → Advanced → Customize Shortcuts.


This topic was automatically opened after 11 minutes.

I have a problem because whenever I copy something in Studio and paste it into another window of Studio and close the first window it was copied from, there is nothing in the clipboard. Will this problem be fixed with this update or will it be addressed in the future?


That is something separate. This update gives you new options for how objects are inserted, but there’s no change to how we load up or clear the clipboard.


I don’t think a model can be added to your actual clipboard, that’s why it only works while the original Studio file is opened.


Can confirm I’m having the same issue, which only started occurring recently; I didn’t see it happening before the two commands were added, so I’m unsure on these features’ correlation to the bug.
EDIT: Bit different from your workflow, this issue occurs to me even when I don’t close either studio windows. This only occurs with Ctrl+Shift+V specifically.


It should help a lot when a good part of your Workspace is below the 0 Y axis level.

Why do the new options appear for non-3d instances? For instance, when copying decals, you have the option to paste into at original location, but it doesnt do anything different from paste into


This is a nice addition, thank you!

Does this work in the script editor?

1 Like

This update has seemingly broken Ctrl + Shift + V entirely. I can no longer “paste into” even after adjusting keyboard shortcuts >.>



It’s extremely convenient, I would even say essential, to have the option to paste non-3D objects than
to not have the ability to at all.

For example, if someone were to replace/remove the primary paste function so they would only use the new ones (they always want pastes to be in their original position) and it couldn’t paste non-3D objects, they would have to use both the normal and the new paste methods with different keybinds instead of just these new paste methods. Which could really hinder productivity/ease of use.

1 Like

It seems the Paste At Original Location doesn’t exist (or it was not renamed yet):

1 Like

AFAIK, the basic Paste function is not available in the Explorer, only in the Viewport. Since the basic Paste function is not available in the Explorer, the Paste At Original Location is not going to be there either.

You can find the Paste At Original Location in the context menu when right clicking in your Viewport underneath the Paste and Paste Into options.


You’re right, thanks.


It would be nice if the paste options were merged into one instead of bloating the context menu.


In fact a lot of things in context menu could be merged


Since I’ve noticed the addition of these 2 new options, the shortcut for Paste Into (Ctrl + Shift + V) no longer works. The shortcut is visible in File → Advanced → Customize Shortcuts but nothing happens.


Yup same issue here. It’s more annoying than I thought it’d be. At first I thought my keyboard was the problem!


I can confirm this issue for myself and two of my colleagues.

There seems to be a workaround (until it breaks again): right click the instance you want to paste into, and select the paste into option. Not only will this do what you want, but it’ll also “fix” the keybind being broken until the keybind breaks again.

So this is why CRTL + SHIFT + V ain’t working anymore…

Get the QA team before relea- oh wait, it’s gone.