The Paste Into Shortcut (Ctrl + Shift + V) No Longer Works

Reproduction Steps

This issue has been occurring in every place that I’ve opened in studio (Team create and non-team create). Many others have noticed this and commented on this in the New Paste Command Options for Faster Workflow post.

I’m using on a Windows 10 PC, Intel(r) Core i5-8600k @ 3.60GHz, 16 GB Ram, Radeon RX 580. The only Beta features I have enabled are CSG V3 and Save rig with animation.

Expected Behavior

Ctrl + Shift + V should paste into, like it did previously.

Actual Behavior

Quite simply, the Paste Into shortcut doesn’t work in studio. Even if you change the shortcut keys for Paste Into, it seems to still not function.

As a developer, I use the Paste Into shortcut to easily transfer instances quickly and efficiently within and between places. Since it is a habit to use Ctrl + Shift + V (and it is probably the shortcut that I use the most), having it not functional has been hindering my workflow a decent bit.

Workaround

The current workaround for this is to right click and manually select Paste Into.

A workaround found by @MineJulRBX_FS is to Right ClickCopy an any instance. After doing this your Ctrl + Shift + V shortcut will be re-enabled for a little while

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2022-06-27 00:06:00 (-04:00)
Date Last Experienced: 2022-06-29 00:06:00 (-04:00)

36 Likes

Related topic is here.

1 Like

I’m definitely having the same problem and it’s really taking up more time than needed just to paste into using CTRL+Shift+V.

1 Like

I’m not able to reproduce this. There definitely is some problem since there too many people that report it to be blamed on a dirty keyboard but I also reinstalled studio for an unrelated issue so maybe that’s why :thinking:

1 Like

I have this issue too. It was so nice having the Paste Into and now it’s dead.
I literally used it ALL the time and now I have to Right Click and select Paste Into.

Classic Roblox breaking the good features.

1 Like

I thought it was just my trash computer, but this has been happening a lot not a lot every time actually :face_with_monocle:

1 Like

I have seen more than 100 tweets on my Twitter timeline(lots of front page devs) reporting this issue. Ctrl+Shift+V is a standard that you see everywhere and it really affects workflow if altered.
Personally I didn’t experience this issue until I specifically attempted to cause it to happen. For me it only occurs when I first open/restart studio, touch nothing else but copy something and attempt the paste shortcut. If I right click or touch other things, the shortcut works again. Which still is odd and it should always work.

1 Like

This issue seems to affect Studio on macOS as well. The keyboard shortcut for Paste Into in Studio (⌘command + shift + V) has not been working for me recently. I am using macOS Monterey 12.3.1

1 Like

same. ive tried reinstalling studio and that hasn’t worked :confused:
literally needs a fix asap i use it so much

1 Like

I was about to report the same issue. I’ve re-installed studio several times and even tried manually changing the shortcut in studio to no avail. It seems like there is no way to trigger “Paste Into” without using the right click context menu anymore.

Thanks for the report! We’ll follow up when we have an update for you.

3 Likes

It was found that the cause of this bug was the Paste Into shortcut. Since it has been reverted, this no longer is an issue!

1 Like