Normal and Bump maps not showing on MeshParts

When materials are used on MeshParts, the bump and normal maps do not appear. Foil appears flat and Plastic appears flat, even though the diffuse and specular maps appear fine.

The mesh that is shown was uploaded pre-materials update.


There are many problems with mesh parts. Especially with textures.

1 Like

Yeah, seems to just be foil and plastic. I’ll take a look.

@Oseday: Texture alpha not being transparent is a known issue. I talked to the rendering team about this awhile ago and there doesn’t seem to be an easy fix. The current workaround is to set MeshPart transparency to a value higher than 0.

What are some of the other issues you are seeing?

One of them is when you have a seam line and use mirrors on the sides, the texture has blank parts on the seam line or where the mirror meets it.
And the edges of the texture blocks feel out of place when compared with what I see on Blender. I’ll try to produce them again when I have time.

Can we actually have normal maps on MeshParts ourselves?

I’m sorry for reviving this.

1 Like

There are several feature request threads for this, consider reviving one of those instead of this bug report. (absence of a feature is not a bug)

There’s also some insight here by zeuxcg:

1 Like

This is still happening.

The bottom one is a normal BasePart, and the top is the same part exported to Blender then imported as a MeshPart. As you can see, the upper one is appearing flat.

Repro steps
  1. Open MaterialsTest.rbxm (4.4 KB)
    in Roblox Studio.
  2. Increase quality settings to max.
  3. Compare the two parts in a well lit area.

Is the material actually brick?

Yes, they have exactly the same visual properties and the MeshPart has no texture.