Output spammed with "Failed to load Animation - sanitized ID" for ID's that aren't in the game upon startup

Whenever starting a new session, regardless of whether it’s studio or client, you’ll be met with these loading errors.

This issue seems to have started merely a few days ago, I wouldn’t say more than a week.
I’m not quite sure what’s causing it; but running commands to find these IDs don’t return any results, not in pre-runtime, not during runtime.

local ancestor = game

local function checkPropertiesForID(instance, property)
    local ItemID = string.match(instance[property], "%d+")
    local found_id = table.find(assetIDs, ItemID)
    return found_id

for _, d in pairs(ancestor:GetDescendants()) do
      if not d:IsA("Animation") then continue end
      local found_id = checkPropertiesForID(d, "AnimationId")
      if not found_id then continue end
      warn(d, found_id)

Using CTRL+SHIFT+F to do a global script search also brings up nothing.

So far it’s happened in this placefile: Test environment polishing stealth NPC - Roblox
But mine isn’t the only one affected by this issue, as you can see in this thread, other people are experiencing it as well.

As seen in this thread:


I’m also experiencing this issue. I’ve noticed that the id in the error is the same as the animation I’m trying to load, but without the first character.


I have the same issue right now, the first number of the ID is missing causing it to not load. Instead of it being 123456789 its 23456789. A bit frustrating.


This has started to appear in the game client too. Just tried to do a game test with some of my testers only to be greeted by nothing other than default posing and all moves inaccessible due to reliance on KeyframeReached.
I hope this gets resolved soon.


Yeah… This is happening to me aswell.

I think i forgot to mention my screenshotting wont work so i got the image from my someone else to clear up.


My theory on a temporary fix to this is to add a random 1 digit number at the front of the real ID, since everyone’s first number keeps disappearing in the output. Haven’t tested this out yet.

Edit: nevermind, i just checked, this issue seems to be fixed now.


This bug is happening to me as well but it only happens for me when I change the animation I had to an updated version of it after saving it to roblox, copying the animation ID and putting it in an animation object.

Found a temporary fix: I exit the Roblox studio place go into a different place then leave that. Next go back into the Roblox studio place with this issue and the error shouldn’t show up again and the animation will work


Can reproduce, however with just a clean baseplate. If I disable the animate script though the errors disappear. I think it might have something to do with it.


I’ve tried this, it doesn’t work. The error in the output is correct, but the animation still fails to load.

1 Like

Hoping we get an administrator response soon, this heavily impacts my game as when animations fail to load, many weapons break!


Having the same issue. Hoping this gets fixed soon!


Same issue here, and I think its causing more issues than just filling up the console.

It seems like this is also filling up the 256 animation track limit on an animator, which is obviously a huge issue. Any workarounds?


I’m not having this bug. Could you try with a blank character and no animation in a fresh place?

1 Like

I am currently having this bug as well. Seems to happen to newer animations only (years old animations that I have seems to be unaffected)


I found a weird behaviour with this error message. It says that the ID rbxassetid://4674372949 cannot be sanitized, however, this ID is wrong. What actually failed to load in my game was AnimationId

rbxassetid://14674372949 (notice the 1 in front)

So the output is listing the wrong animation ID, and if I remove this animation, the entire animator works again. Mind you, this animation was first uploaded a few minutes ago as new.

EDIT: Oh, seems like people already mentioned this above. Though I’ll keep it in for clarity sake. Wrapping it in an error handling pcall does not seem to do much either as it still breaks the entire script.


For me it seems like pretty much every animation is affected:

Some of these have not been updated for 3 years.

The thing with the ID is the same for me as well. To find the real animation ID you just have to add a random number from 1 to 9 to the front of the sanitized ID until you find it I guess? I dont know why thats a thing though


can confirm as i’m facing it right now as well.

for some reason the the very first “1” on an animation id seems to be removed which leads to the ID changing entirely

example “14674366744” turns into “4674366744”. could this be a case of digits limitation ? cause this seems to be happening to all new ids i’m currently uploading. i hope this gets fixed soon as i literally can’t load any of my animations LOL


using a URL like http://www.roblox.com/asset/?id=########## seems to mitigate the effect of the incorrect animation id but the bug still stays

You guys are really clicking on the url :rofl::rofl:


if you got all the way down you simply have to wait for the animation to not be sanitized anymore. It took around 15-20 mins for one of my animations


:grimacing: seems to be happening to me too . the thing is I don’t even know what’s causing it … Does this have to do with a loaded animation ?

1 Like

I only have one day before school starts and i need these animatons for my game to work I NEED THEM!!! >:(