Permissions bug - Group-made animations do not load for Team Create members in Studio

Reproduction Steps

  1. On your main account, publish a game to a group that you own, and turn on Team Create.
  2. Upload a custom Animation to that group, and set up a script in your game to play that animation.
  3. In Game Settings > Permissions, give a second account access to edit the game.
  4. Log into the second account, and open the game in Studio using that account.
  5. Test the game in Studio on the second account and attempt to play the custom animation.

The following place file can be used, just replace the AnimationId of Workspace.Animation with the animation that you uploaded to your group.
AnimationBugTest.rbxl (31.4 KB)

Expected Behavior
I expect the animation to load and play correctly when editing the game from the second account.

Actual Behavior
The animation does not load when using the second account to test the game in Studio. Animations will only load in Studio for the owner of the group, not anyone else.

In this case, animations can only be tested by publishing the game and joining a live server via the website. The inability to load animations in Studio is a major hindrance to other members of our Team Create.

The only way to fix this is by granting the “Create and edit group experiences” group permission to the desired accounts, which will allow them to load the group’s animations in Studio, but this is not a suitable workaround when you only want to give people edit permissions on specific games, not every game in the group. Since animations load properly when playing the published version of the game, they should load in Studio as well.

Below is a video of me testing a game on an alternate account and trying to play a group-made animation. The animation cannot be loaded at first, but after I give that account the “Create and edit group experiences” permission in the group, the animation does load.

Issue Area: Studio
Issue Type: Other
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2021-05-01 00:05:00 (-04:00)
Date Last Experienced: 2021-07-08 14:07:00 (-04:00)

9 Likes

This severely affects my team’s workflow.

This makes professional development with contractors extremely difficult and makes managing permissions separately impossible. This is something that needs to be addressed.

3 Likes

Thanks for the report! Are you still encountering the issue ?

2 Likes

Yes, this issue is still occurring.

2 Likes

We filed a ticket to our internal database and we will investigate the issue further. Sorry for the delay!

3 Likes

any update on this? seems like its still a problem for me