Please, oh please, can I just keep these old icons?

I’m not sure what I did but when I launched Studio from and clicked “edit in Studio” on a sub place within a universe ( instead of just clicking the edit button on the games page on, it launched an older version of Roblox Studio with the old icons:

These icons make so much better use of color and are much more visually clear to me. I’ve been really trying to like the new icons but I just can’t. They’re almost all the same color and this makes them harder to read at a glance. The Play Solo button looks the same as the run button, every script icon looks the same until you take a second glance, and other UI changes like the removal of these buttons;
It all makes me loathe the newest version of Studio.


For the love of God and all things holy let me keep this

An option to be able to select which theme and button layout would be nice at the very least if this feature can’t be implemented instead;

Or at least use a theme more similar to the one in their example:
This continues to make good use of colors to improve visual clarity and readability at a glance while still making Studio look more modern. It improves the look without sacrificing functionality and usability.

Thank you for taking the time to read and consider my desperate plea.


Roblox is actually releasing theme support, you can change the icons and itll pull from there if told to in the settings, which allows to change some, or all of the icons, i do hope they allow you to change the actual backgrounds though, being able to change colors of the widgets would be really nice.

Was mentioned in the same post you mentioned
Custom Studio Interface (Themes and Icons) - #5 by PoshKiwi



PLEASE add these buttons back. They were so convenient and y’all are hindering my workflow :sweat_smile:


You can add these back in the quick access toolbar in the top left corner of Studio. There is a very small dropdown arrow at the end of the bar of small icons to the right of the File button.


it doesn’t solve the problem. It simply edits the organization of the icons.


It does solve the problem though? Click the arrow, then Customize..., search “device”, click the first result, click Add >> and then click OK. Done.

1 Like

Ah, my bad, I didn’t see him reply to the screenshot above him.

Found out how to do it myself:


I don’t like how the better DPI handling is attached to the icon changes too in the Beta features list. I really don’t understand why… I just want my monitor to work properly but I need to use the new icons in order to have it function properly? Kinda frustrating

I think this is a great idea.

One way old icons could be enabled is with an option in settings, like “Use legacy icons” or something along those lines.

I really miss the old icons and am finding it difficult to use the new ones; I’m just used to the original ones by now.


I like the new icon design, but i despise the way it affects color recognition. I feel like ROBLOX is trying to follow the simplistic design trend, but the way ROBLOX thinks about how their updates will affect their community needs to change IMO.


Honestly, I think they are a massive step up from the old icons (except the black icons, please say that’s a bug)! Also the icons come from the Silk Icons Pack, which are a set of stock icons. They are free to use, but ask for attribution. Iirc, Roblox has given no attribution to the people behind them, which could be a problem.

i am now stuck with these icons that in my opinion look very very ugly. where is the option to disable this…?


I am so sick of these icons it’s infuriating not being able to switch to the old ones


Developers should be able to switch to the PREVIOUS icons and the NEW icons freely.


check if you have more than one Roblox Studio installed. For a while at least, one of them had the old icons and the other had the new ones.

If that doesn’t work, make sure you’re not in the beta channel by opening Studio and going to File>Beta Features and unchecking “Enroll in Beta Channel”.

If none of that works out, you can at least use a custom icon pack now. I use one called Vanilla 3 which is free.

It is fully possible to override the icons now with your own icon set, and some people have already published the old icons set up this way in #resources:community-resources .


please, im begging. I thought it was a bug at first, but its been this way for months…

The best workaround at the moment for this is to do the following:

Select the dropdown arrow by the icons above the ribbon bar and next to the “File” dropdown and select “customize” at the bottom

Then, search for “Device” (for mobile device emulation) and “UI visibility” in the search box on the left, click the result, click “add”, check the box on the item that appears on the right, then click “OK”.

The buttons will appear on the bar above the ribbon bar next to the file button.

It’s annoying they have to be up there but this is an adequate workaround, for me at least.

You can also bind a keyboard shortcut to these actions if you like by selecting File>Advanced>Customize Shortcuts… and searching for the same things you searched for when adding the buttons to the bar above the ribbon bar.

1 Like

I honestly find the new icons confusing, its kinda hard to find the things I want to find, everything looks so greyish… I don’t know its just unfamiliar.
If there is a way to use the old icons I dont know how to do it :sweat_smile: