Problem with discord webhooks and roblox http requestes

  1. Hello, Recently, i’ve got a problem with my discord webhooks: they aren’t working anymore. Let me explain: My script was working, after this, i opened roblox studio, i made some changes, i published, and the webhooks are not working anymore
    By the way, http requests are allowed in the game settings. image

Error message:

  1. So, as i said, my webhooks are not working due to an error (HTTP 403: Forbidden), but http requests are allowed…

  2. I tried to use, but it was not working… I tried using “” and not “”, but nothing changed… it was still broken.

BTW, this is the script i’m using:

local https = game:GetService("HttpService")

local webhook = ""

function sendDiscordMessage(message, name, picture)

	local info = {
		content = message,
		username = name,
		avatar_url = picture

	local encoded = https:JSONEncode(info)
	https:PostAsync(webhook, encoded)

Oh and, i forgot to tell you something:
Webhooks are working in Roblox Studio but not In-Game so… Yeah, idk.

Anyways, Thanks for reading and have an amazing day / night!


Hello this has been asked a LOT frequently.

Discord blocked Roblox’s user agent. You will have to proxy the request.


Discord blocked roblox from using their webhooks, instead use a proxy. An answer has been posted in this post.
Note that many other posts with the same issue have been posted.

1 Like

Again? Seriously? I thought they just changed this a few months ago (from the time of the post)…