Random UI Fragment Appearing after Run Testing (New UI)

I can confirm this is happening aswell. In most cases when I have 2 instances open, the viewport just completely disappears until I close that window

Yeah, as cool as the new UI is, it’s an absolute joke and simply too unstable. Would love to know how they decided to push it out. I’m using Studio Mod Manager for the time being to use the version prior to it. What’s interesting is that I am now also getting problems with widgets that get stuck on the screen and cannot be closed in the older version, ever since the new UI was released, albeit extremely rarely as opposed to very frequently with the new one.

Can confirm, the update did seem to help a bit, but the issue still remains. It makes local server testing unusable.

Hi @jgrimm1, can you please list some of the steps that you do during your server testing process that result in the issues you’re having? Also, what is the resolution and scaling of your display?

I am still having the same issue

I noticed that, but for me it goes away.

I’ve noticed that completely wiping Studio from my system (uninstalling via Add or remove programs in Windows Settings, removing any left over Studio files in AppData/Local/Roblox/Versions, removing these folders:

  • [folder with a user id as its name, in my case it was named 500634351]
  • ClientSettings
  • InstalledPlugins
  • placeIDEState

also removing these files:

  • GlobalBasicSettings_13.xml
  • GlobalBasicSettings_13_Studio.xml
  • GlobalSettings_13.xml

and removing Studio’s registry key
(Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio)) seems to have fixed all of the issues mentioned above, however it does come at the cost of losing your settings, widget layout and probably some other things

1 Like

Looks like this glitched plugin screen also can’t be properly closed when studio closed:

It seems to be whenever I try to start a local server test with any number of players.
My screen resolution is 1440p and scaling is 100% on Windows.

Local play tests seem to be fine.

1 Like

I tried reinstalling studio but that didnt fix it. However when I deleted the regedit key, it was fixed.

As of an entire month later, I still get this bug and it is not from a plugin but it is from the plugin menu. I find that when I open the plugin menu it goes away.

Please Roblox I’m just trying to do my job, why am I having to deal with this

1 Like

Yep, I’m still getting all of these problems too. It’s ridiculous.
What’s even more frustrating is that I can’t use the older version of Studio prior to this new UI now, because it’s “too old”, forcing me to use the latest version.
These problems are now interfering with my every-day experience and my job as I work full-time with Roblox.

I can also confirm it’s still happening very frequently. Very annoying

Yup still happening. Still getting the random box and still getting the blank screen. Love it

1 Like


These issues are the highest priority for us. Please use the directions in this post as a workaround while we fix this @Timelens @CrispyBrix @CaptinLetus @Orodex.

I had this happen when starting a playtest server, have Studio freeze and while it’s frozen, spam the stop button even if it’s not enabled yet until the session stops, not sure if this is already reported on the replies so just adding it here to make sure

Thanks for your reports! This should be resolved now. Please let me know if that is not the case.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.