Return InBrowser. InApp is bloat

InBrowser should be an option for Desktop users. Power users, like playtesters, seriously benefit.


InApp has been bloatware pushed on desktop users lately in the recent less stable client releases.
People have been circumventing it, but now roblox forces the regedit back, making good solutions absent.

When live Playtesting, I frequently join and leave a game many times, and this timewasting UI bulkiness adds up rapidly. Personally, attempting to Alt+F4 does not close the session properly, and the client continues to stream in data from the server in the background. (A serious bug in a live launch?)

One of the greatest Freedoms of a Desktop platform is the absolute control of executables. Why is it being removed?

This even misintentions some competitive games ‘Nico’s Nextbots’ for example where a player wants to casually but abruptly leave, now is jinxed by a clumsy 5-10 second farce of an exit menu while their live session continues to uncontrollably run in the background and penalize them for it, losing all their progress.


Thousands of individuals have voiced their frustration with the menu publicly:

And lots of talent and time has already gone in to haphazardly disabling it:

74 Likes

Nothing against the feature request, the app is pointless. But surely this is an indirect way to stop combat logging?

This is a misunderstanding of how different platforms approach web applications. Mobile it makes sense to bundle an app layer ontop of the game layer as thats better for UX, however on Desktop platforms, probably everyone launches games from the Browser, and it makes no sense to have an idle DataModel running for the app’s functionality in the almost 0% case I actually bother to use a mobile app ported to Desktop.

This also isn’t mentioing the abysmal performance of the Beta app because they’re using Roact again lol.

Also just press Alt+F4 twice even though thats a super alien UX pattern

7 Likes

Exactly my thoughts.

You shouldn’t be requesting a big feature they brought in to try and bring the entire user experience together to be removed just because it makes it harder for people to combat log in a game.

3 Likes

Salvaging this as ‘Inbuilt combat logging’ reaffirms its missing the target, most games aren’t competitive, its user experience friction. “We’d rather play Steam.”

A chechbox combat log feature delivery, spectacular. But that’s not this.
This is a small bluff players have to climb. They’ll play 9 games now, not 10.

1 Like

I disagree, sure some Roblox games have combat, but not all do. In addition, to prevent combat logging, Roblox could just make the player stay in game for a bit longer after they leave. Plus combat logging is niche, only highly competitive games really care about it.

The cased I’d make is that it keeps users on the app for longer (similar to the mobile app)
So that instead of potentially being distracted by other web applications, they get returned to Roblox to play a different game.

3 Likes

Since using this exe, I havent been able to play roblox

I think its because I didnt fully update Roblox before activating it initially and that raised hell
I didnt agree to the updated TOS in the app, for example

Tried everything on the forum (setting date and system time auto, https://en.help.roblox.com/hc/en-us/articles/203552894 ) I could find for it. I also completely wiped every ‘roblox … .exe’ on my computer except prefetch (everything app). Restarted and shutdowns for a bit.

Waited 12 hours until now, uninstalled client and then again reinstalled from site, and still no give.

I’m told doing that should clear all changes made by the inapp exe,

so can I provide you anything to make sure DisableBetaApp didnt leave anything behind?

It only changes one registry key, I’d advise checking the registry at CURRENT_USER/SOFTWARE/Roblox Corporation/Environments/roblox-player/ as well as the Versions folder under it

There might be some messed up versioning data in there, but it updated seamlessly for me?

roblox-player

inBrowser


Versions

one unset value


fresh install

Delete the version0 key and set the two other version hashes to version-0

This should HOPEFULLY trigger a reinstall, but of course I cant say for sure here

Deleted version0.

other version hashes to version-0

Versions ‘(Default)’, roblox-player ‘version’ I presume?

I set their value to version-0’s value


When I exit 280. it exits me to the inApp webhomepage, so that’s something
but still 280.
If I click on a play button inApp webhomepage, nothing happens.

edit:
You might have meant roblox-player curPlayerVer and version I realize
those were already the same value as Versions version0 however.

Ok yeah I dont actually know what’s happened here, Roblox has definitely become corrupted somewhere because it didnt install properly

I dont even know if it was my tool that caused this or just Roblox’s launcher being incompetently coded (i will assume its a problem on my end though so I’ll try to figure out whats actually happened later, im out rn)

It’s account-specific

I tried chrome, edge, with my other accounts. App runs.
Made a new account to test Firefox, App runs. Its specific to this account it seems.

Extra:
I wiped Firefox, disabled all plugins
I had wiped the Registry of Roblox,
and deleted anything Roblox including InApp from the whole computer.
the reinstall did have a significantly different value for version.

but now my main work account is useless for live testing. Epic sauce.

Do you mean Roblox account or windows account

My tool changes the registry key at HKEY_LOCAL_USER/SOFTWARE/Classes/roblox-player/shell/command/open or smth along those lines

Roblox account.

I just downloaded your latest release, and ran it, and it pops up a Firefox window, of course, on my main, as thats what is logged in again.

So it has an impression of being atleast Browser-centric and not system universal, but Im asking you for grasping some straws here.

For instance if I run chrome right now, I still have inApp. Your exe didnt do anything to the other browser-account pairs I have. Just Firefox and this account, forwhich is unobservably affected due to it having Update 280.

Running the app without any launch data just runs the launcher with no parameters (which will open Roblox in the browser)

This is a launcher issue and not my tool. And honestly I’m lost on whats causing it now.

There’s a ghost in the machine

should I file a Web Bug report?

Here’s the basic workflow

Identify launch mode (browser or in game)
If in game, strip out InApp parameter
---------
Find active launcher based on version hash
Set roblox-protocol handler to said launcher in registry (used to trick roblox into not reinstalling)
Start launcher
^ this is where i believe the issue is
----------
Wait for launcher to finish
Change roblox-protocol handler to the disabler app

I’ve pulled the executable from GitHub until I can find out whats happened (likely wont)

1 Like

At the time of writting, @pobammer 's DisableBetaApp.ps1 · GitHub is effectual
For accounts not stuck in ‘Update 280’, which is probably a false positive condition of the roblox client launcher

1 Like

100% in favor of removing this GARBAGE. It’s actually the worst update Roblox has pushed, maybe ever.

Roblox, please, please, please take a hint. We do not want this, it is a waste of your time to continue pushing for it.

12 Likes

Yeah, for months this has been happening even if u just press the close button. I’d hear the game music for literally 10 more seconds before it fully closes out. It did lower to a maximum of 5 seconds or not at all, so they fixed SOME of it lol.

2 Likes