Rig not moving the correct parts

Hello, I am trying to rig a model of a character from a horror game (I’m also trying to make the rig like dummy rigs since I don’t have a lot of rig experience) and I am using the rig edit plugin. When I try to animate the uppertorso, the uppertorso stays in place and the lower torso + legs move instead, and when I try to move them, they move in the opposite direction. I can move individual parts of the head, arms, legs, etc, but I can’t move either of the torsos using their correct parts. When I try to move the lower torso, nothing happens. It would be too much to add the hierarchy so I will be including a video, screenshots, link to the package I made, and an rbxm file. Also, I have tried moving the joints around (from HumanoidRootPart to the other torsos) but have had no luck.
Joints:

Welds:

Video:
robloxapp-20240625-1250337.wmv (1.5 MB)
Link:

Rbxm:
rig.rbxm (4.0 MB)
Sorry if this is a lot, I know I’m not very experienced. Thank you for your help!

2 Likes

Have you tried to Unanchor everything?

1 Like

Everything is already unanchored, I don’t think anchoring is the issue here.

when I checked the file I selected everything and anchored and then un-anchored it.

I also noticed that since your main parts are the Interior wire skeleton that’s within the mechatronic, it makes the parts hard to select in the animation editor.

I tried anchoring and unanchoring and nothing changed. Also, I have no trouble selecting parts within the editor.

that’s interesting. Is the .rbxm you posted different from the one you are using? (is your Roblox studio different maybe? (have you tried turning it off and turning it on again?)

1 Like

Oh wait, I got it to work! Thank you so much, It’s weird because anchoring is one of the first things I checked for, and nothing was anchored. I tried again and it worked!

1 Like