Roblox Code Editor Extremely Buggy On MacOS

After the recent studio update my code editor has gone from normal to extremely laggy. The change is very noticeable and the new code editor is persistently a few seconds lagged behind my input(I timed it) in both scrolling and typing.

I have a 16’’ MacBook Pro 2021 with M1 Pro @ 16 gb of RAM running MacOS Monterey.

I’ve done some testing, everything I report here is based on qualitative data, what I can observe, so I did not track FPS when scrolling thought code:

  1. Script length has no effect on lag.
  2. Errors or using intellisense has no effect on lag.
  3. Color modes have no effect on lag.
  4. Nothing in the 3D view effects lag.
  5. My CPU and GPU usage are both below 10% and I still lag.
  6. My RAM usage is below 10gb and I have 16 gb of shared RAM and I still lag. Just as a side note I have used 40 gb of ram in the past(utilizing swap RAM to overcome the 16 gb of installed RAM) and my computer still ran smoothly in the code editor and all operating system.
  7. Closing all other windows changes nothing.
  8. The only way to make the lag go away slightly, it’s still laggy but noticeably better, is to change the code editor window size down to something very small(around 1 inch by 1 inch real world size, which is unusably small). As a note I have a 16’’ almost 4k display(3456 by 2234, but I run it with more space at over 4k resolution, changing it down to a lower resolution does help the lag for the same reason as making the code editor smaller). So basically either lowering the resolution of your display or making the code editor smaller helps with lag.
  9. Deleting preferences has no effect on lag.
  10. Reinstating has no effect on lag.
  11. Changing the zoom of the code editor has no effect.
  12. Want to note that all other scrolling frames are smooth for me, like scrolling through the explorer tab is still smooth even if its flooded with thousands of open folders with hundreds of objects in them(my game has 200+ weapons each with many complex parts and organized into folders). Though it would be nice if Roblox Studio could support promotion(120hz refresh rate).

Seeing as the only way to make the code editor run smoother is to change the resolution of your display I would say this issue has to do with using the code editor in high resolution. My current solution is to change the resolution of my display down to 1080p when coding(which is still noticeably laggy), and when not coding move it back up to 4k.


We’ve filed a ticket to our internal database, and we’ll follow up when we have an update.

Thanks for the report!


Same is happening with me also if i type “” in a script it error like print(“a”) will error.

1 Like

Been dealing with this as well. I hope this doesn’t take as long to resolve as it did a couple years ago when Studio for Mac was having similar issues…


This is probably related to this:

Though macs don’t have G-Sync, so I cannot be sure. Try changing your monitor refresh rate (if possible).

Update: Roblox seems to have fixed this issue. After the latest update my code editor is running smooth again! I wouldn’t say it 's back to normal, but is much, much better.

1 Like



1 Like

More Mac script issues inbound. It appears every time I try to open or edit a script, my Roblox crashes…
I’ve made a bug report on it already, but I suspect these issues might be related…

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.