Studio Design Refresh causes NVIDIA G-SYNC to tank framerate

Reproduction Steps

1. Ensure “Adaptive Sync”/“G-SYNC” is enabled in monitor’s hardware settings
2. Enable G-SYNC for windowed and fullscreen mode in the NVIDIA Control Panel
3. Open any place in Roblox Studio

System Information

  • AMD Ryzen 7 3700X 8-Core Processor @ 3.6GHz
  • 16GB DDR4 RAM 3200MHz
  • NVIDIA GeForce RTX 2070 SUPER 8GB

Additionally, the monitor I’m experiencing this issue on is a Samsung LC27RG50

Expected Behavior

Studio should operate normally with no noticeable effect on performance or framerate.

Actual Behavior

Studio immediately slows to a crawl of less than 2fps upon connecting to any game.

This issue does not affect Studio’s game select page but does affect both the game viewer and script editor once a project is actually open.
Before the “Studio Design Refresh” update, this behaviour only affected the script editor and as such was much less prevalent and easier to work around.

This bug is reproducible on my end 100% of the time by following the outlined steps.

Workaround

While not ideal, this bug can be worked around by disabling G-SYNC in the monitor’s hardware settings or through the NVIDIA Control Panel prior to opening Studio.

Alternatively, selecting “Enable for full screen mode” instead of “Enable for windowed and full screen mode” in the NVIDIA Control Panel partially resolves the issue.

Issue Area: Studio
Issue Type: Performance
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2022-09-10 14:09:00 (-04:00)

5 Likes

I’ve had this issue since the beta started. I managed to find a workaround through using the Mod Manager by Clonetrooper. Works without needing to disable G-Sync each time you want to use studio.

Since I have seen this bug before, I know that this is partially true. However, it also occurred while playtesting, and the script editor could be undocked with no frame drops.

Thanks for the report. I filed a ticket to our internal database.

3 Likes

I exclude the program in my Program Settings in the NVIDIA control panel. However every studio update you have to do it again.

1 Like

What is the workaround? For me, Studio lags really badly when I move the mouse cursor around at all during testing, even on the default baseplate. I’ve checked the control panel and I don’t have G-Sync, but there has to be a cause for this almost-unplayable lag (in Studio only, not there when using the Roblox Player).

1 Like

Did you check the NVIDIA control panel? To access it, you right click on your Desktop and depending if you’re running Win10 or Win 11, you might need to press “Show More Options” before seeing it.

I can’t explain it in a good way so here is the the link to it. It was made by one of the most reputable devs on the platform too.

image
Yeah. There doesn’t seem to be a G-Sync option in the sidebar so my monitor must not support it.

Oh… I already use Mod Manager so I can use the new IKControl instances and Vector3:Angle() early; I’m wondering if the workaround involves any other FFlags.

Also, I guess my lag isn’t related to this bug report since I still have the old UI and don’t know how to force the new one.
The old UI visibility and device emulation buttons
I recall having the redesigined UI at one point but now I’m stuck with the old one.

1 Like

This is happening to me on a Mac. Why is this refresh not a beta flag?

1 Like

G-SYNC absolutely destroys my performance on studio.

Script editor lags like there is no tomorrow, and honestly makes working in studio impossible. If not for doing a lot of research and coming across this issue, I would be stuck and not be able to get anything done. This needs to be fixed ASAP!

2 Likes

I find it mind-blowing that this has not been resolved yet. This forced studio refresh “upgrade” has destroyed my FPS in both the game window and script editor, not to mention the numerous other bugs I have encountered. My workflow has been severely affected with no way to opt out. As a Mac user without G-Sync, none of the solutions above work for me, leaving me with a completely unusable studio.

1 Like

If you don’t have G-Sync, then you probably have a different issue.

2 Likes

Thanks for your reports, everyone. Does there continue to be lag on the new update with the icons reverted?

It doesn’t lag anymore for me.

1 Like

Yes, I am still receiving lag even after the update.

Unfortunately yes, the issue still persists exactly as described in the original report. No change in behaviour what-so-ever. :frowning_face:

I’d also like to add onto this quote by saying this workaround has to be redone every time Studio or your NVIDIA drivers update. It’s a pain but seems to be the best solution so far.
(Studio Mod Manager for me did not run on the latest version, meaning I couldn’t access any of the other features added alongside the design refresh; not to mention the issue still persists in the script editor regardless.)

EDIT: I was mistaken, Studio just so happened to have an update coincide with my driver updates :grin:

1 Like