Roblox games load for about 3 seconds then instantly crash

If the UWP Roblox app has issues (such as shift lock not locking the mouse), you should report those in a bug report by messaging bug support.

Someone stated earlier that pressing okay on the dialog box within about five seconds will prevent Roblox from crashing. Does this work for you?

1 Like

Is there a way to download that?
Im not able to access the Microsoft store


You can try downloading the .APPX file, but I have no idea where to find it.

1 Like

Using this tool (, you can retrieve the *.appx for Roblox using a link from it (which would be Get Roblox | Xbox), you will need to download the very last result and then rename the file you get (it will have no file extension) to an *.appx.

I had troubles getting it download for myself, so you can download the installer using the download link I am hosting using Discord’s services just in case you can’t figure it out.

Let me know if you have any issues.
- Knew

1 Like

I know this isn’t relevant, but please never do this again. It can harm your system or apps dearly.


I agree. If anyone has to clear the Roblox registry, follow this guide:

1 Like

I was told a couple of weeks ago that it was a complex multi-threading problem (for me), and that it should be fixed by V575.1 V575 ← (released), almost V576. What is going on??

Still experiencing this issue, sent logs to DM’s but no response. I’d like to disclose the dmp files I found recently privately to avoid any account issues resulting from releasing those to the public. Hope this get’s fixed soon.

1 Like

Still happening for me. Games will work fine for a day or two then a crash happens and it will crash on a white screen when I try joining any games. Restarting my PC always fixes the issue, but is annoying to require daily at this point.


I get this problem too, after a few hours of my PC being on, it will just refuse to launch Roblox and rebooting is forced to fix. But it doesn’t even resolve the ‘memory dump’ crashes, which for some reason only sometimes appear, but switching between the two different file locations allow for me to get that memory dump error.


I sent the issue out to Roblox, and I am pretty sure they fixed it.


seems like they fixed the issue…

Hello all,

I apologize for the delayed response, but I was out of the office for the past 10 days. Here’s an update on the different issues that have been mentioned:

Last week, we did not release a new client version due to issues unrelated to Hyperion. Unfortunately, this also means that the fix for the multithreading issue that @Threllz is experiencing has been delayed.

The issues @AbstractAlex is facing are related to a very old bug inherited from the 32-bit client, which seems to be more prominent in 64-bit environments. I am actively working with @AbstractAlex on the issue. Approximately 1/5 of the submitted crash dumps I have received indicate the cause of the crash is related to the same bug.

I am slowly working through my inbox, which has become quite large over the past 10 days. Once again, I encourage everyone to report issues properly rather than sending me direct messages.

Thank you for your understanding.


Hello MJ07619,

After analyzing the crash dumps we received from you, we have determined that you are using or have used an injector. Unfortunately, we cannot provide any further support for this issue.


Been having issues with Roblox ever since the 64-bit version rolled out, the worst probably being that the client wouldn’t even open. Also, I am very frustrated for having to wait about two-and-a-half weeks for my devforum account to finally be promoted to where I could post.

Without getting to posting logs or crash dumps or repos, I just want to say I just made a massive breakthrough by pure happenstance. For some reason, the Roblox client would open and almost instantly close on my main user account, but switching to a different Windows user, I was able to open it and play games (albeit with some other issues). This issue for me seems to be directly related to the “VIA HD Audio Deck” program.

  • With the program active, the Roblox client closes almost immediately after opening.
  • With the program closed, the Roblox client opens and otherwise seems to behave normally.
  • With the Roblox client open and the program closed, opening VIA HD Audio Deck and then switching to the Roblox client causes the Roblox client to close.

I’ve been having a similar issue and therefore cannot acquire any crash dumps. Once the player opens, it immediately closes. I have tried closing all other applications to no avail. I also tried the disk cleanup method and that did nothing either. Furthermore, there’s nothing of value in the player logs.
This issue has been going on for many days at this point and it’s very annoying.


Hey, Just a quick reply noting that i forgot to configure it to do a full dump, So i have and i have let it crash and make a full-size 1gb crash dump (avaliable from the same dm link)
Hopefully this helps and I wish the team the best!

1 Like

I sent a message to the Bug-Support team like 4 days ago which goes into detail about this issue, but it’s gone unanswered even until now.

Any chance you could tell them to try and look for my message when they’re able to? There’s images of error messages, detailed findings and a memory dump that should help them aswell.

Not really sure why there’s inactvity, but hopefully someone can read it soon enough.


Roblox Player updated and the issue is now completely fixed, so just discard this.


With 577, I’m still experiencing a behavior where, after having the Roblox client open for hours, minimizing it to look at another window, and then trying to maximize it again later sometimes causes it to silently crash. Produces no crash dump, no Windows error, nothing of note in the log file.

1 Like

Hello 10xTheFoxy,

Analyzing the crash dump you provided, it appears that you are facing the same issue as @AbstractAlex. The root cause of the unrecoverable error is a failure in the Windows API call CreateDIBSection(). This failure should not occur since a process is normally allowed to create up to 10,000 GDI handles.

To gather additional information about this unusual issue, could you please:

  1. Set the registry value Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\GDIProcessHandleQuota to 64000.
  2. Reboot your system.
  3. Test if the issue persists after implementing this change.