Roblox games load for about 3 seconds then instantly crash

30 FPS? You’re lucky. Lots of people get only half that. Also, what’s with the russian nvidia website?

MSI Afterburner is deprecated software that has no alternative to it, just like the MSI web server from 2013.

Oops, forgot to change language on the link

I can’t get any Roblox application to launch.
The loading box appears and Roblox just chills in the background doing nothing for 20 minutes until I start hearing the background music from the games I try to join. After that either nothing happens or it shows that the application crashed.
I’ve been contacting support but all I’ve gotten in response is the most obvious fixes I’ve tried a 100 times before even messaging them.

Cleared all files and cache from roblox, reinstalled many times, restarted my pc a ton, tried running it in compatibility mode, tried running it as admin, giving the apps firewall priveledges, turning off antivirus and whitelisting the programs, updated my drivers.

1 Like

I also have this bug. I play for 10 seconds and then my character plays the walking animation while standing idle, then crashes. I blame Byfron.

My system specs:
Lenovo Legion 5 Pro Gen 7
Intel Core i7-12700H
16GB DDR5 Memory

1 Like

Hello bnx,

This definitely doesn’t sound like a Hyperion issue. However, if you do have a crash dump, please forward it to us.


Hello ants,

Please send me a full crash dump as outlined in Strategy Three here


I have also recently seen crashes when playing roblox while other Easy Anti Cheat games are running (For example: Fortnite)

Very similar to the wireshark crash I mentioned at the start of the hyperion release, however this time, it crashes between 1-5 seconds after launch. Im suspecting it is the anticheat trying to intercept the process in order to verify the legitamacy of the process

I have logged 2 crash dumps according to the strategy 3, totaling around 5GB size, I can send it to you in DMs if it is needed

1 Like


I’ve been having this issue since June (roblox crashing at/moments after launch), and despite my best efforts with WinDbg, I’ve had no luck determining what’s causing the crash. None of the loaded modules seem out of the ordinary or anything. Here’s the full 600mb crash dump- any help would be greatly appreciated!

EDIT: Additional information- booting into Safe Mode lets me launch, but attempting a clean boot doesn’t. I am running the latest possible version of Windows 10.

1 Like

OS: Windows Server 2019 Datacenter with GUI
CPU: AMD FX-4320@4.0GHz
GPU: nVIDIA GeForce GTX 1070
RAM: 32GB [4x8GB]
Hello, I got crashed Roblox since July 2023, recently in event viewer called AutoVerifierV2.
I’m trying to update the graphics card, operating system and also reinstalled Roblox but, keeps crashing after the launch and in game.

I am also having this issue, no idea of what’s doing it though.

EDIT: This may have something to be with windows insider’s newest versions, since on other threads with the same issue people have seem to have found that


I’m having the same issue using Windows 7 Ultimate. I don’t know why but I’ve messaged crash logs to @Bitdancer in hopes he can fix it for me.

Edit: After looking through the posts in here, I noticed mentions of Test Mode.

Now, the thing is, I cannot boot outside of test mode due to Windows 7 not loading NVIDIA’s drivers if I don’t use it, a potential solution for Roblox to implement would be to whitelist any system using test mode with NVIDIA GPUs installed, as it is required to have GPU drivers to run Roblox correctly.

There is NO other option for me. I MUST use test mode otherwise I won’t have a GPU.

I don’t even know if it is test mode, as I crash with or without it enabled, but please, Roblox, look into this, as I am not upgrading to Windows 10 to play Roblox.

1 Like

Windows 7 isn’t officially supported by Roblox anymore, so it’s probably not being maintained for old drivers

Cap. Windows 7 just requires a number of updates to be installed for Roblox to run on it. It’s probably because you tried it on the RTM release build 7600 with no updates installed.

  • PC/Windows: Roblox will install on 64-bit versions of Windows 7, Windows 8.1, or Windows 10. For Windows 8.1 you will need to run Roblox in Desktop Mode, as Metro Mode (the tiled start-screen) is not currently supported.
    Note: The Roblox website supports the following browsers for PC/Windows: Chrome, Firefox, and Microsoft Edge.

Sorry to be the bearer of bad news, but test mode is not supported. This compromises the integrity of the operating system and is a boot configuration we explicitly forbid.

NVIDIA’s drivers should be properly signed and load under Windows 7. One thing you can try is to use an older version of the driver package from when Windows 7 was still supported.

Same happening to me. Roblox hangs just 3 seconds after I open it, RTX 3060 with Ryzen 3600 CPU. I suspect something with Hyperion or something?

1 Like

Hello miko_miko,

Please send me the full crash dump as described in Strategy Three here


This offer stands, of course, for everybody who is running into issues and is not cheating.


A little unrelated, but I’ve been encountering this issue where my roblox player freezes up immediately on the loading screen and stays unresponsive for the entire time. I am now unable to join any game for approximately a day or so.

^ To see how it looks like for me every single time. Others have also been encountering this, some posted about it on r/robloxhelp.
I’ve sent out a support request and didn’t really get far yet.
As for what I’ve tried yet: restarting PC or reinstalling the roblox player didn’t work. Other players tried more methods, so I am not really going to bother with all of that, as it doesn’t help.
Anything you could do?

same issue. I cant even open roblox desktop app and its started occurring after update 594.

edit: i dont know how (maybe the problem was in pc) but roblox with no updates after pc restart just started to work :smiley:

edit 2: after another pc restart roblox again broke :expressionless: this problem is very strange

edit 3: roblox is working again after second edit :no_mouth: