Roblox games load for about 3 seconds then instantly crash

Hello Hashtags,

Wireshark and NetLimiter are not explicitly blacklisted. I suspect that their incompatibility falls into the category mentioned here: [64-bit client] Crashing after a couple minutes of play, every time - #5 by Bitdancer

While this may not apply to the software mentioned above, we would like to pose a general question to the community: Why would seemingly harmless and innocent software need to require read/write access to another process, and what does it do once access is granted?


This ‘unexpected client behavior’ as well as the “unexpected error occurred” have been happening to me and a lot of people I know. It seems to happen a lot when trying to load into a large terrain map


You guys have done something wrong for sure, Didn’t one of the engineer say that FPS Unlocked was whitelisted by byfron? Because right now what i can see is that we get kicked for having an FPS Unlocker on.


I joined ONE ROBLOX experience and as soon as I left to go to another one, I was hit with the same error. After reinstalling and restarting my PC, I was met with a ‘Failed to load SensApi.dll’ error, but miraculously I was able to join games.

I don’t understand how this company fumbles around with their updates so much. Even now, I have an issue with voice chat not working at all, despite it previously working even WHEN the anticheat was implemented yesterday.


Continuing the discussion from Roblox games load for about 3 seconds then instantly crash:

I’m experiencing a similar problem but not with loading instead I’m able to play fine but just after 10-15 minutes of gameplay the game would crash and become unresponsive and present’s me with a white screen saying Roblox “Not Responding” at the right corner or the game just closes completely after being frozen.

This only started after the new updates including the Byfron Anti-Cheat, I’ve notice when I’m using the 32-bit client the game would run smoothly and I experience no issue’s but after a recent update my game has became 64-bit and after awhile I’ve started receiving these issues.

Reproduction Steps (Consistently Every Time, On All Games):

  • Join any game play around for 10-20 minutes and eventually I’ll crash (can’t spend an hour in a game without it exiting my client).
  • Sometimes even just joining a experience and loading after three sec’s it’ll crash.

Solutions Tried:

  • Ran RobloxPlayerBeta & RobloxPlayerLauncher as Administrator and In Compatibility Mode
  • Re-Installed Nividia Driver’s
  • Turned off most third-party apps (Roblox FPS Unlocker / Shaders)
  • Re-Installed Roblox & Deleted All Files From it in my directory incase of corrupted files remaining from previous installs
  • Not using a VM or VPNS

My System Specs:

  • NVIDIA GeForce RTX 3060
  • AMD Ryzen 5 5600x 6-Core Processor, 3701 Mhz, 12 Local Processors
    RAM 16.0 GB
    VRAM 12k
    1TB HDD
    100GB SSD - (Roblox Is Here)


  • Window’s 10, 64x - based PC

Video Example Provided:

Image Example Provided:

If needed I can provide a crash dump.


Hello Jzk,

Please send me your crash dump so we can narrow down the issue.


I also have this issue; HOWEVER it doesn’t crash after 3 seconds. It crashes after about 15-30 minutes and it’s getting rather repetitive. I believe this associates with the new 64 bit update as my Roblox client is incapable of upgrading.


I’ve sent you my crash dump in PM.


Where can I access my crash dump to send you?


Hello CarBluGStudio,

You will find the crash dumps in %UserProfile%\AppData\Local\Roblox\logs\crashes.
In my case, that would be C:\Users\Bitdancer\AppData\Local\Roblox\logs\crashes.

It is fine to delete the whole %UserProfile%\AppData\Local\Roblox\logs folder prior to creating a new crash dump to keep the clutter to a manageable level.

Hope that helps


Would it be possible to send you a crash dump from my friend who is facing this issue?
He seems to be facing the same circumstances as Jzk.


Of course, go ahead, but please do add your friends username so I don’t mix up stuff.


This is my friends (mattdoot)'s log file


Update: Roblox doesn’t even open and attempt to open the game anymore. I click play then it just closes by itself.


I got this problem but its happens in some games…


I’ve had a similar issue for the past 2 days haven’t been able to figure out the problem. I see the roblox game client on task manager for only about 2 seconds until it disappears and nothing else happens afterwards.

So far I’ve tried to

  • re-install roblox
  • Clean boot
  • Updating driver
  • Updating windows

Despite all these, the issue does not change and continues happening 100% of the time.
The task manager also says “Roblox (32-bit)” despite reinstalling, so unless that’s just a visual thing I have no idea how I would fix that.

Last time roblox worked normally was 4/5/2023 (DD/MM/YYYY) at around 2 Am EEST.

Issue cause has been found.
HitmanPro.Alert service (an anti-malware) mistakes (assuming) roblox game client for a malware, and blocks it immediately.
Disabling it in System Configuration (msconfig in search bar) OR making an local exclusion to RobloxPlayerBeta.exe and RobloxPlayerLauncher.exe should make roblox work again if you have the same problem as I do.

I’ve been told the issue is being fixed.


aren’t you supposed to send it privately?


Hello all,

This is a reminder to please file a bug report if possible. Only if your score is not high enough, should you send me DMs directly. DMs need to be manually triaged and this can significantly slow down the process of finding a solution.

Thank you for your understanding.


Having same issues, all though it only crashes when I launch it for the first time on startup or new fresh client install. (The game does load then crashes after with the old cursor.)


Here it is.
0.574.1.5740447_20230505T204239Z_Player_B56FF_last.log (3.0 KB)