Roblox Kills Internet Connection

First off, I am well aware that this category is not the best place to post this. I would much rather post it under Bug Reports so the chances of an engineer seeing it is higher, but I do not have a high enough rank to do so. Due to the nature of my issue, it would also be impossible for me to rank up enough to post it there, considering I cannot even use Roblox. Edit: I messaged the bug support group and am hoping the topic can get moved.


Above is a short video recording of the problem I am experiencing. Around 1:05 is where the client freezes and the issue occurs. When I try to use Roblox Studio or join any Roblox games my internet gets completely shut down for a couple of minutes before coming back on again. Every device connected to my WiFi loses connection.


A few things to note

  • It only occurs when my computer connects to Roblox. Other devices are able to play without issue. This means that it is unlikely that it is a problem with my internet.

  • I only have this issue with Roblox. No other applications or games.

  • It is a somewhat recent issue. I have been able to play and develop on Roblox for years without this problem.

  • I can open older versions of Studio (old Future Is Bright beta versions that I have saved) and use them without the issue occurring. I cannot use these versions of Studio for actual work because they are a couple of years old.

  • When I am on the Roblox Studio startup page (where you can choose templates and other games), the issue does not occur.

  • My internet does not come back up until I close all of the Roblox windows I have open. After I close them, my internet comes back on after a couple of minutes.

  • I have run a network monitor to see if Roblox is using too much bandwidth and causing my Router to get overloaded. I did not notice any abnormal amounts and it was actually using about the same amount as Chrome. I am not really experienced with this kind of thing so maybe take it with a grain of salt.

It has been months of me having this issue, with it worsening over time. When it first started I was able to work/play without issue and then only on certain days would this issue occur. Over time it gradually became more frequent and now it is impossible for me to use Roblox Studio, join games using Roblox Player, and the issue even happens with the Roblox app on the Windows store.


Things I have tried that have not worked

  • Restarting my computer. This is pretty obvious but I should still put it here.

  • Restarting my router.

  • Resetting my router settings.

  • Disabling my router firewall.

  • Getting a new router. My ISP has sent around 4 new routers and 3 technicians to try to fix the issue. To no avail. I do not think my internet is the issue.

  • Checking if Roblox is using too much bandwidth. More details were stated above.

  • Reinstalling Roblox.

  • Making a guest account on my computer and seeing if it works from there.

  • Using a VPN

  • Trying it in a virtual machine

  • Pretty much anything that initially comes to mind, I have tried. It’s been close to a year.


Currently, I use Studio by opening a place file as fast as I can and disabling WiFi in Windows settings. This is pretty impractical considering I cannot work with other people, I cannot upload things, and it is hard to even publish things.

I do not think this is an issue with either my internet or my computer due to the fact that it has worked fine for years and is now a recent issue. This is kind of a shot in the dark considering the state of the DevForum and the fact that I cannot post in the correct category. Any real help would be truly appreciated.

18 Likes

Never happened to me but hope this gets fixed, but Honestly it’s weird because I don’t know any single case of this bug so yeah.

4 Likes

I can relate, since last updates Roblox screen freezes rarely.

2 Likes

Roblox freezes then crashes, and it’s a similar issue. Hope this gets fixed!

2 Likes

Good luck getting this fixed. Roblox has been freezing and crashing recently, so I’m assuming it’s a similar situation.

1 Like

Wow. Just watched the vid. Bizarre behaviour, but I doubt this is truly caused by Roblox Studio or Client and may just be a symptom of something else. The browser appeared to show a DNS timeout when trying to load, which is unusual.

So, open Task Manager, connect to a game and watch the Performance tab > Ethernet stats. You will see a peak as the game info is loaded. See how high this peaks at and for how long. I can get upto ~100Mbps for some of the more detailed games.

If your peak is sustained for a long period of time, it may be that your wifi or internet bandwidth cannot cope with the amount of data coming through, thus saturating the link. Try running a speedtest from your device to see what it reports.

If these tests all appear ‘normal’, hop back in to Task Mgr, open Processes tab (might have to click "More details: to get full view, then click the Network heading to sort the processes by how much data they are sending/receiving. Load a game a see what happens in this area.

As the browser reported a DNS error, open a command prompt (press Windows key + R), type ‘cmd’ and press Enter. Type “nslookup www.roblox.com”, to check the IP to DNS name lookup. Do the same thing again as you experience the problem with your internet connection. Does it will provide a response?

If it fails, check your DNS settings. In the command prompt type “ipconfig /all” to show you your full IP settings. Funnily enough, doing this has shown me that the entry set as my primary DNS no longer responds so I need to fix mine.

I think there will be quite a few more troubleshooting steps to nail down the issue, but you need to work through them to fix this messy business.

2 Likes

Try to dm @Bug-Support if not ranked up…
Thats look like a ram issue. Try to switch pc.

I wish it was more common knowledge that you can just message @Bug-Support and they’ll make it a topic in the right category.

1 Like

I do remember having an issue similar to this where when I started Roblox while a TV was running (live TV), all the internet and TV cut out for all devices in the house. It started happening a few days after arriving to the place, kind of “gradually” getting worse like your issue it seems.

This was around a year ago, and I don’t think I was able to find a solution (I ended up just moving back to my original house and it was fine). Im not a networking expert, but I strongly believe the IP i was working under when this was happening had something to do with this. Maybe specifically the Roblox app got black listed by the internet provider and as a safety measure the internet was entirely cut off when Roblox was in use.

Maybe to narrow down the issue further:

  • Try using a different account on the device that has the issue in question
  • Try using a VPN
1 Like

Thanks so much for replying! When I originally posted this I was not really expecting any actual responses.

Here is a screenshot of the graph that shows when I join and the moment that it disconnects. I am not sure how useful it will be since it does not show the full thing. It does show that my internet goes down when Roblox is loading and not after it.

Above is a video of the processes view in task manager. Roblox used a peak of 5.4 Mbps when loading. I think it loaded a little while after that and the moment my internet went down was when it said 0.1 Mbps. After it went down it took Roblox a little while to disconnect.

image
I don’t have great internet but it has never really been a problem in the past. I’ve been able to play with lower speeds than this on more demanding games. My brother has no issues with using Roblox on his computer either with similar speeds so I think my internet should be able to handle it and that the problem is something with my computer.


Last night I did a bunch of tests. When I type the “nslookup www.roblox.com” before joining Roblox it returns results and is able to return results up until my internet goes down. Probably the expected results.

Currently, I am using my ISP’s provided DNS server. I switched to using Cloudflare’s DNS servers in my computer settings and then in my router’s settings. The issue still occurred both times.

My internet also still went down when using a virtual machine. I was not really expecting that one to work but I thought I’d try it.

I did find out that I was able to play extremely basic games with no issues. I was able to stay in a default baseplate template game with no problems. I was also able to play one of my older games that only had only a few parts. When I tried anything slightly more complex the issue started again.

Thanks so much for letting me know. I had no idea.

1 Like

I am almost 100% sure it is not a RAM issue although I can see why you might think it is. I have 16 GBS of RAM and I’ve never had any issues with not having enough. Telling somebody to just switch computers is not a solution to ANY problems and could probably “fix” almost any computer-related issue. It’s just not practical to get a whole new computer just for this.

You can probably DM @Bug-Support and ask them to edit the category. Make sure to give them a link to the topic.

I’d recommend setting your Primary DNS server to be your router and then get the router to do the heavy lifting, not that DNS is heavy in anyway at all.

The next place to check then is the Roblox local client logs. On Windows, open File Explorer and browse to:
C:\Users<your login>\AppData\Local\Roblox\logs
Connect to a game wait for it to die, then check the latest log file in there. The logging is very good and should show you what is happening for the client (but doesn’t explain the whole DNS thing).
Let us know if you see anything unusual in the logs.
NOTE: AppData folder is hidden, but you can type it into the address bar and it will navigate to it for you.

1 Like

Any updates on this? Keen to hear how it is getting on

1 Like

Sorry for the late response. School started back up yesterday so I’ve been busy with that.

I am not entirely sure what I should be looking for in the log file, but there are a bunch of “HttpError”, “HttpTraceError”, “SslConnectFail”, and “HttpError: DnsResolve” errors near the end. These are really vague especially out of context so I am not sure if they would be much help.

Is there anything specific I should look for in the logs? Thanks so much for continuing to help.


I believe this is unrelated because I’ve asked other people to check their logs for it, and it is also there with a few variations.
image

Not really sure what this is but thought I might put it here just in case.

An example of me suddenly getting a high network ping a subsequent disconnect here:

The important info for you will be down near the bottom of the log. Log timestamps are local time, so check the time when things start to go wrong and then look in the log around that time period.

I would be interested in seeing exactly what it is saying. You can just trim the timestamp out and put the relevant log data. Don’t post any of the stuff form the beginning of the logs, just the timeout stuff.

This is from the “AckTimeout: Last Packet received time” to the end of the file:

Above this screenshot is 30 lines of “Failed to load sound” errors if that helps.

OK, so 85000milli seconds (ie 85 seconds) response time is horrendous.

If you are on a WiFi connection, try and take your device closer to your router and see if you still get disconnects. If you do, then try a LAN cable directly from your device in to the back of your router. It should have the local LAN ports marked, if not read the manual.

This will tell us if the issue is purely down to the link between your device and the router. It might be that there is a weak signal between your device and your router causing a very localised issue.

I have a desktop computer so I can’t really move it closer to the router to connect to it. Since I have DSL WiFi I do not think I can move the router itself closer to my computer to connect it either. The 85 second response time error also happened after my WiFi went down and I left Roblox open for a little while. I guess it kept throwing out errors while it was frozen. Before my WiFi gets shut down my ping is pretty normal.

Some info I can provide that might help tell if it is because of a weak signal is:

  • I’ve used a friend’s laptop while the issue was occurring with a weaker connection (The laptop was getting way slower speed test results) and Roblox worked fine.

  • I have used multiple different WiFi adapters and the issue still occurred. I even tethered my phone’s WiFi connection to my computer and my internet still went down. I am able to play Roblox mobile on it fine though.

  • The issue did not occur on my computer in the past, even when I was getting slower speeds than I am getting now. I have not moved my computer anywhere different.

Sorry that I can’t connect to my router directly. I don’t want it to seem like I’m not trying to solve the problem.

I will also note that when Roblox does cause my internet to go down, I am never fully disconnected from the WiFi connection. I am still able to access my router’s control panel and change settings.


image

When my internet goes down, the “WAN Link” status in my router’s control panel changes from “Up” to “Down” but the “WAN Connection” status stays at “Connected.” I hope this makes sense. I’ll attach a screenshot of when it is up for context.