Roblox Player crashing (only in my login)

I have a Windows 10 with 3 different logins.
As of the last Roblox update, when I try to test my game with the Roblox Player, it stays active for a few seconds and then crashes:


However, this does not occur in the other 2 logins of the same Windows.

I’ve tried uninstalling and reinstalling the Player twice, but the problem persists.
Here is the current log:

0.573.0.5730507_20230428T123107Z_Player_773E7_last.log (42.5 KB)

How to solve it?


It looks like the problem is similar to:


Looks like a bug with the 64bit client. Only 25% of the playerbase have it right now to catch issues before full release. Have you tried re-installing?

1 Like

That’s even painful to play, been trying to play other games and at first it crashed until attempt 4 and it ran just perfectly fine.

sometimes just doesn’t respond and sometimes doesn’t render a frame but the game is still running (simply trying to hover on ui and the sound plays but client didn’t try to sync or run)

1 Like

1 Like

Hello rogeriodec_games,

Please provide us with the corresponding crash dump. This will help us investigate the issue more thoroughly and identify its root cause.

I sent you the download link in PM

Hello rogeriodec_games,

Thank you for sending us the crash dump, and based on it, we have found that the reason for the crash was Hyperion detecting what we call “badware.” Badware is typically some form of cheat software, but it could also be malware on your machine or a badly written driver.

We recommend performing a clean boot and attempting to run Roblox again. Additionally, as a precaution, we recommend thoroughly cleaning your computer using various virus scanners and malware removers.


I have another Roblox installation on a Windows 10 VMware.
There, I called Roblox Player, it auto-updated and then crashed (it didn’t even enter the game).
Then I performed all the steps for the clean boot, I did the boot, but it keeps crashing.

I sent you new logs and dump in PM.

1 Like

Hello again rogeriodec_games,

We received your crash dump, and as you mentioned, all of them show that the Roblox client is being executed in a virtual machine. Currently, Hyperion intentionally crashes clients that are executed on a VM.

You are saying that Roblox will no longer work on a VM???

That is correct. To quote from the post linked below: “You will also find that we blocked the usage of VMs for the very same reason.”

Ok, before I have a psychotic break with your statement, I need to make it clear that I have been using Roblox Player (for years) in a VM simply because Roblox Player does not allow multiple simultaneous instances with different users in the same Windows session.
Testing my game on Roblox Player in a VM is the only way I’ve found to be able to test multi-user behavior with real users.
Preventing Roblox Player from running in a VM will simply prevent me from testing my game.

Now, I think it’s clear that a multi-billion dollar company like Roblox is always looking to improve their products, rather than going backwards like in this case. So, I think, Roblox must certainly have a Plan B, like allowing me to install a 32-bit version of the Roblox Player or anything else that allows me to test my game in a VM…

1 Like

There are tools available to accommodate multiple instances (I can neither confirm nor deny if they are functional on zwinplayer64, that you will have to see for yourself), you can also use Microsoft Store Roblox in addition to zwinplayer64.

That’s not the point. Roblox is supposed to make life better for developers, not worse, leaving us to work out the limitations imposed without any prior authorization.

I didn’t need to do a clean boot.
I found that this crash, in my case, occurs when I have the Process Lasso program active.
So, there is no “badware”, no “badly written driver”!
I use this Process Lasso to weight down concurrent processes.
It works perfectly, and it always has, but now with this new version of Roblox Player, the Player crashes.
The only way now to run my Roblox Player is to CLOSE this program first.
This is inconceivable! :rage:

1 Like

Hello rogeriodec_games,

Thank you for your feedback. We are pleased to hear that you were able to identify the issue. To provide further clarification, the term badware refers to unsigned software that opens a write handle to the Roblox client process. This does not necessarily mean it is malicious software. Another program that falls under this category is dtrace as we just discovered.

Unless there are further issues you would like to report, I’m going to go ahead and close this ticket.

Best Regards,

1 Like

Will it stay like that?
Won’t you make an exception for this program?

1 Like

Forget it. I have already discovered how to reverse this tyrannical imposition.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.