Roblox silently loses connection without notice or rejoin option

From what I’ve observed, there’s an absence of a mechanism to patiently wait for the connection to stabilize and then reconnect, which seems to be a key factor in these disruptions.

It’s worth noting that many other games utilize such a system, where a brief wait period allows for connection stability before initiating a reconnect. It seems peculiar that Roblox doesn’t incorporate a similar approach.

I believe that Roblox should implement a system that handles minor network changes. A short wait and reconnect period could make a significant difference, allowing players to seamlessly continue their experience without the frustration of sudden disconnections.

6 Likes

Not to mention, the sudden disconnects often toss me out of the game when I’m playing with friends.

This often results in me losing status and points I got in round-based games or leaving friends and people behind in cooperative games that require team work.

Games like that often also don’t let you rejoin until the round is over so losing connection due to a minor networking hiccup is quite frustrating I must say.

2 Likes

Hi, we are having this problem!

2 Likes

bump
Problem still persists within roblox exclusively.
Does not happen with any other game or platform :C

2 Likes

For me, it shows the error message after like 5-20 minutes of this silent disconnection. In the past, I could move around for half an hour without being notified, now with new PC it is faster.

I must clarify that the internet connection affects this thing. We live in a house with strong, thick walls. When I sit in the livingroom - the place where the router is - I don’t get these silent disconnections (maybe I got once but after really long time of playing). If I go to my room, which is second room in L shape (so basically the internet goes through the wall connection of 4 rooms), I get these silent disconnections pretty often. Like … really pretty often. In my own game, there are no more than 10 minutes of playing and I get disconnected. And that is not a shooter or a PvP game; it is pretty peaceful and calm (unless you get driven by a bus, haha).
This silent disconnection happens even if I am alone in the game (no other players), although then it is harder to notice.

I found a game that really struggles Bloxel - Roblox. This game sends A LOT of data to the client (which seems to be from a chunk loading system, similar to minecraft). It often takes less than a minute for the network to completely freeze, and I get kicked about a minute later. If it doesn’t freeze, there are good chances it will freeze later on where I move to another location and it has to load more chunk data

I’m using wifi, with my pc kind of far away from the router (I have a feeling the stability of the connection plays a role in how often this issue happens)

I’m pretty confident it’s related; client → server communication still works (chat messages are still sent when the network freezes) but server → client communication stops completely. The kick message seems to be something that was added recently

3 Likes

Hello, I do not know whether my testimony may help anyone. A few months ago, I had a very bad and unstable connection (ping spikes from 80 to 17k) but I had never experienced this issue before. In december, I got optic fiber installed which resolved all the latency and loading issues as you may guess, but I have started experiencing silent disconnection issues. As a side note, the IP changed, but none of the hardware nor client app were changed. Installing Roblox Player did not fix anything, using a PC with Ethernet cable or a laptop with WiFi 6 did not either.

Recently, for new year, I came to my grandparents’ with the same laptop I have mentioned above and have tried to play Roblox. Shockingly, I have no disconnecting problems, so I have come to the conclusion that this problem may happen to certain people depending on their connection (likelihood of the IP, the speed or the ISP). I had issues installing Roblox Player and Roblox Studio before and I am not able to tell you whether this issue is linked. (link here)

A solution I may attempt soon is that my grandparents’ own a router which is able to host an OpenVPN solution and I may connect to there from house provided that this problem does not happen here. If this solution works, I will post a new message in this thread.

3 Likes

This issue is probably more widespread than it appears on the surface, affecting most likely thousands of players. My friend has had this issue since late 2021, with their client silently disconnecting every 5-20 minutes, and it has gotten more frequent over time. When they stay in the game for about 5-10 minutes after the silent disconnection, a pop-up appears with the 277 error message.


Someone on Reddit here appears to have a similar issue, if not the same. There are also dozens of comments on this YouTube video that describes something similar, and while they all might not be related, I wouldn’t doubt many of them are.

@Tomi1231 and @omer_y have the most rational assumptions about why this is happening. It doesn’t appear to be exclusive to Windows users, nor hardware-related.

I encourage people to post, even a video of it occurring so that this thread is bumped. I think Roblox Staff are underestimating how much of an issue this really is.

5 Likes

I have been having this problem as well. The game will just freeze and there will be no network activity. Resetting the network connection doesn’t do anything.

2 Likes

Is this issue being investigated? We still haven’t received a follow up from any staff members. It would be greatly appreciated.

12 Likes

This is still an issue I run into to this day.

Frustrating about this problem is that some games handle lots of player actions client-side before replicating on the server so sometimes it takes a solid minute to notice that you’ve been disconnected.

I’ve ran into this problem multiple times the last 2 weeks and lost some progress/rewards in games because of it.

3 Likes

It also happened to me when i was using a different wifi,
I switched my wifi, the issue has gone,
Literally, the ping gets infinite.

Try using a different wifi if possible

1 Like

I have a strong feeling that this issue is not being taken seriously. Whether on this post or any similar ones, so far we have received no real answer.

As far as I have read on various sources, this problem exists since 2021 and I believe it would be a great option to post a new report, yet given the new options to report bugs, either one of us has access to bug reporting or we are stuck. Way more people than I thought happen to have similar problems.

Over a few months, I have made my own investigations and I would appreciate if anyone could confirm some observations although I am still thinking about the fact it is entirely linked to one’s network (IP address) and not due to material.

Could you provide more details about the way you have fixed it? Are your different WiFi connections on the same network, or do they have different IP?

Regarding myself and as I have said before, when I am using 4G or 5G, I do not have this problem. Please try as well and if possible come to a conclusion on whether this still happens to you.

Amongst my observations, I have come to the following conclusions:

  • If you press SHIFT+F3 and observe the “income” section, when happening, it will slowly reduce to 0. I do not have any concrete explanation to this.
  • If you are using Vocal Chat, you can still listen to others and talk to them, they can listen to you.
  • You can still receive data while you have actually lost connection. Example: you are playing a game that requires exchanges between you and the server like clicking. You may see the rest of the other players moving as you’re receiving data, but you are not sending anything, the server does not register your actions (you do not send data so to speak). After a while, you will lose all receiving and sending packages.

Obviously, this is a part of my observations but my old report got declined due to the bug reporting changes. Could anyone confirm these? Any addition to those observations is welcome.

1 Like

At some point, this report and my report got an “Open” status manually added to them; They were both filed prior to the introduction of bug report statuses. I’m pretty sure they’re aware of this issue and might be actively investigating it. My best guess is that they’re just having trouble reproducing this issue (as it has been awhile since I’ve experienced it myself). I agree, though, that a follow up from the team assigned to this issue would be nice.

1 Like