Roblox Studio will ALWAYS update when opening a Place from Web then from File System and vice versa

When I open a place from the website and then open a place file from the file system Roblox Studio will update

When I open a place from the file system and then open a place file from the website Roblox Studio will update

this causes a lot of annoyance to our workflow for developers who delete built-in plugins and uses Vanilla because on each update Roblox Studio files will be replaced with a new one

this is really hindering my workflow and ability to work I literally can’t have a place file opened from the file system while also having another place opened from the website

20 Likes

I had that bug yesterday, but was able to fix it. Try going into any roblox game and getting the roblox client to update, after that studio should stop multi-updating. It’s kind of a weird bug.

I’m not sure if this a Studio bug because, the same happens to me when my internet connection is slow.

I’ve tried opening Roblox Studio with a slow internet connection and it would update every time I launch it, but freezes at the login screen with this message:
LoginError

1 Like

I am having the same problem, I almost lost some progress due the shutdown thing but I could publish at time. It is getting really annoying.

1 Like

Hello! The issue you are experiencing is caused by having stale Studio shortcuts. When experiencing this, please:

  1. Close all running instances of Studio.
  2. Delete any local Studio installations.
  3. Launch Studio from Web.
  4. Update shortcuts to point to the freshly installed version.
2 Likes

I’m not sure if you mean to go into where studio is installed and start deleting folders or files relating to studio because I tried uninstalling it the normal way through control panel and this problem still occurred.

image

image

image

The studio shortcut still existed after uninstalling studio, so I deleted the shortcut as well as the executable file the shortcut lead to, then tried launching studio from the website. The website prompted me to download studio since it couldn’t detect the program anymore, so I ran the installer and the problem is still occurring.

2 Likes

Yeah this exact problem is still occurring for me, and it’s really hard to work when I can’t have a file studio open and a studio from the website. I’ve also tried uninstalling and reinstalling already.

This wasn’t happening before a couple of weeks so there is definitely something wrong from Roblox’s side not us.

I noticed that it replaces a new version of contents in %appdata% every time it updates so that might be related?

I have this bug too, I just deal with it lol.

Yeah same. Its bug update multiple.
Look like gauntlet game player move go around loop of room.

Can you please post About box info for Studio launched from web and launched from shortcut? Thanks!

1 Like

Roblox Studio Bug1

Can you please edit the target location from file/run app so that it matches the one from website and check if the issue still occurs?

Yeah
C:\Users(name)\AppData\Local\Roblox\Versions\version-daf37e0153f84ffd\RobloxStudioLauncherBeta.exe -ide
There update is back old roblox studio.

I’m having a similar issue, only this happens when opening the Asset Manager as well. When I open from the web, it thinks that Roblox needs an update and updates. Then, I open Asset Manager and open a file locally and it thinks that I need another update and updates back to the old version.

So first, I install Roblox fresh (delete all versions and use the installer) and then open from the web. Old is the one from the installer and new is the one from the web wanting to update:

After opening Team Create, I end up with this:

Then, I load up an old save of the place (using Asset Manager) and THIS happens, it reverts my studio back to the version before opening team create through the web. I literally can’t open a reverted place and a team create because of this.

1 Like

Been having this issue all week, who let the intern publish the update?

1 Like

Same here. random update.
Shortcut: C:\Users(Name)\AppData\Local\Roblox\Versions\version-35c8e137c2354c29\RobloxStudioLauncherBeta.exe -ide and load place from website.
And run app or open place from files there update is back.

Staff you need fix all roblox studio.

This has been really ruining my workflow. It’s really an issue for developers like me, who use different places for different things and try to move files from one to another quickly.

2 Likes

Issue is still persisting too, where’s the actual update on this? Clearly a roblox issue yet no actual help besides just changing locations…

1 Like

There bug update:

1 Like