Scripts work in Studio, but not in-game?

First off, I tried to take a gear from lighting to workspace (which worked, but broke the gear). That may have been on my end, but i made a gui shop to. This gui worked 100% in-studio (i could buy and click around like its supposed to do), but when i publish it and go in-game, it doesn’t work? I havent tried a solution yet (dunno where to start, im new to scripting), so any help is appreciated.


First, don’t store stuff in Lighting, use ReplicatedStorage

Second, are you using Accurate Play Solo?

A LocalScript will only run Lua code if it is a descendant of one of the following objects:

  • A Player’s Backpack , such as a child of a Tool
  • A Player’s character model
  • A Player’s PlayerGui
  • A Player’s PlayerScripts .
  • The ReplicatedFirst service

Make sure you are using a LocalScript instead of a Script for Detecting Input.

Game Development Resources [MEGA THREAD]

Basic Scripts

You will be needing those later. :wink:

1 Like

Do not use server sided scripts in local only GUIs. Also, you should watch more coding tutorials on FE / replication as well as some basic tutorials so you can understand when, why, and where to put scripts and what to put in them and what type of script you should use.

1 Like