Server Timeout message displaying in every server

I started to get reports recently that people were “crashing” and that the game was timing out after about 10 minutes of gameplay, and I decided to test this myself. I’ve done this multiple times and every time it had the same result; here is a video, skip to the last minute or so of the video to see me get kicked, it’s 10 minutes to show that I was moving around before it timed me out.

(Video may still be uploading if you’re just reading this now)
Simply put you are kicked from the game and this shows:

In my testing this happens every time the game runs.

This happens at my button tycoon game (please save the criticism lol):

This is definitely not a performance issue, and my internet is always at least 10 up 40 down.

This bug started happening (I got the first report of it) on the 29th of October.

I don’t know what this is and have tried looking for some cause in my scripts but I couldn’t find any reason for this to happen.

Also yes I am moving around and moving my mouse ETC the whole ten minutes before I get kicked.

I could be incredibly wrong here, but if you have previous versions of the place you could go back until you find a save version in which this doesn’t occur, from there, maybe you can determine a source for why Players are timing out.

Not incredibly knowledgeable on this stuff so there’s definitely a chance that it also has nothing to do with the things you’ve created - and it’s simply something on Roblox’s end.

I would do this - but im pretty sure its not something I added to the game, it likely is my own fault but in something that was fine before a roblox update came out.

Ah, yes, that’s the most likely scenario.

Anyone got any ideas on this? It’s really affecting my player count and getting loads of complaints, if anyone knows what the message means or something which could help me fix it please let me know.

I have received help from roblox on this, I should be able to fix this at some point. Thanks all!

Mind sharing what the issue was? People who stumble across this in the future are likely to leave frustrated if there’s no actual solution posted.

No sorry, I didn’t find out the problem, just that it may be caused by lag or an infinite loop calling the client continuously.

I haven’t yet found evidence of this but I would’ve put if I had any more info