Set Animation Priority function not working

I was setting up animations for a simple FPS system and when I tried to make an idle I realized the animation would load. I was troubleshooting it a bit and I realized I couldn’t set the animation priority of the idle animation in the roblox animator demonstrated here.

I don’t know if this is the reason it wouldn’t work but I thought it was odd.

Animation priority is set thru scripts, not animations themselves even if there is a button for it. Read this article for information regarding replacing default animations.

1 Like

Up until now, this definitely was NOT true! There is supposed to be a priority saved with the animation, but this appears to be currently broken! You can see in the video the drop-down box for setting that priority, but there is no checkmark indicating which was selected.

2 Likes

It is not just you. I have 2 animations. One works and one does not.
Both are played by the same script (so not a code issue). The only difference is the one that does not work was published after the most recent studio update. I’ll let you know if I find a solution… my entire game depends on this priority setting.

EDIT: This has been submitted as a bug. Identified 2/3/22

Ironically, setting the priority through scripts has always been the broken one, mainly because of it not replicating. What currently works is setting the priority through the Animation Editor, where it’s automatically saves with the animation data. OP’s problem is that the Animation Editor simply isn’t functioning correctly.

CC @cjhatter