Studio Command Bar Missing

The studio command bar went missing. The button to hide/show the command bar does nothing when clicked multiple times. This issue has never happened before until a while ago today.

I did not move the command bar at all it has always been where I have it and I always have it visible. I was in studio earlier today and it was there. Closed studio for a bit and when I went back into studio it wasn’t there anymore.

Thinking that a fresh install of studio would work, I did that and opened studio but it is still missing and the button to show/hide it does nothing.

Next I deleted Roblox and Studio and re-installed them both. Same outcome, the command bar is no where to be seen and the button to show/hide it does nothing.

I tried to look in studio settings for a way to reset the docks and panels but there is no such option, I wonder why :thinking:

I am opening a project and a default baseplate place has same results.

I asked a few other developers before posting this thread to see if they were having a similar issue, because maybe perhaps a studio update did this for multiple people but so far it seems I am the only one having this issue.


I had this issue before - could not solve it either (it’s only resolved now as I bought a new PC for unrelated reasons).

Might be worth including some information about your machine and studio version, including when this first happened to you.

Does the toggle on the context menu when you right click on the Ribbon Bar not work?

As you can see in my image, my command bar has been enabled.

1 Like

It may have accidentally been shifted/dragged off-screen or it’s on a monitor that’s now disconnected. AFAIK Roblox doesn’t have a way to reset the UI within Studio, but you should be able to reset it through the registry. Search for regedit in the start menu, open it, and navigate to


The command bar geometry is stored somewhere inside RobloxStudio, but it doesn’t seem to be aptly named. You can either dig around for it, or delete the RobloxStudio folder entirely. This will reset all of your Studio settings to default – not just the widget geometry.


The Context Menu and the button under the view tab both do nothing to make the bar appear. I have completely deleted the studio folder the other day when trying to re-install studio. I am pretty sure it was a clean install, no traces of studio apart from my project files and a copy of my plugins folder so I didn’t have to reinstall each one all over again.

I am still having this issue even today, with the latest Studio update.

1 Like

Deleting your Studio folder does not delete your settings or registry data, where the command bar geometry is stored. You will need to follow the instructions in my previous post to reset the command bar.

You are right, that did work. Thank you. I just simply deleted the entire RobloxStudio folder.

Hopefully Roblox will add a way to reset the panel positions without having to do this though.


Do you know where the start menu is? I am very confused about this, sorry for asking 2 years later by the way.


Please don’t necrobump bugs that are marked as solved. You can send a private message if you need something clarified by a poster.