Studio Crashes When Opening The Object Browser and What's New Menus While Editing Place

I never had the issue with the desktop app, but I can only assume it might be related to the same issue

well yeah. on my end the accounts launched from website and the one logged in on the app weren’t the same

I had this problem for over a week now, and just lost a bit of work to it, so I found this thread… updating my graphics driver to latest version via GeForce Experience and also updating Studio (did not test in-between) resolved it.

For what it’s worth, I’m on a Razer Blade 15 w/ RTX 3060 (Laptop); Windows 10

Thanks for the suggestions & solution that worked for me @PoshKiwi

(It also resolved Studio completely hanging without error upon closing the window, including Test Server/Clients)


My studio seems to have been reset to a previous version, and all issues seem to be fixed.


Thank you for the revert! Hopefully this issue can be fixed in the version with the latest icons. :grimacing:

1 Like

Dang, you’re lucky as I am on the latest version of my drivers (GTX 1660 Laptop) and I still have the issue :smiling_face_with_tear:

While experimenting with graphics modes, I found out that Direct3D11 is having issues. Swapping your graphics mode to anything else (recommend Vulkan since it looks visually the same as Direct3D11) and it should work just fine.

Thanks to @PoshKiwi and @ElephantMesh for taking the time to help out. Big preesh!

Edit: To change your graphics mode, you must go to File > Studio Settings > Rendering > Graphics Mode and change it from there. Thanks to @AborayStudios for mentioning this as I forgot to state it lol.


This works! For anyone who doesn’t know, go to File > Studio Settings > Rendering > Graphics Mode. Change to Vulkan then Restart Roblox Studio

One question, why do you recommend Vulkan?

1 Like

Unfortunately, studio updated for me (I assume back from the reverted version), and now I am not able to open studio at all (white screen error, as I experienced before.)

I made sure drivers are fully updated, and am still experiencing issues. If anyone knows a more permanent fix, I’d appreciate it.

Currently dealing with the same problem.

I recommended Vulcan because there is seemingly no difference compared to Direct3D11; mainly visually. Made sure to edit in why :+1:

If you are using Direct3D11 as a graphics mode, try changing it to something else that is compatible. I recommend Vulcan since it has little to no difference from Direct3D11 visually.

Graphics mode is a studio setting, correct? For me, studio isn’t opening at all (freezes immediately when I try to open even the “place navigation” menu), so I cannot change it. :grimacing:

May be a different bug than on this thread, but I assume it is related, as it arrived at relatively the same time. There are no current workarounds that I have managed to find.

Thank you. I may have had to tweak your steps slightly, but it is working for the time being.

Edit: Studio still broken. See below. :pensive:

At this point, I’m experiencing the studio freezing error, with Graphics mode set to Vulkan.


Nevermind. Studio is just as broken as before.

I highly suggest reporting this issue using another bug report as this seems to be a different issue that may be related to something different if the workaround isn’t working for you.
You can send one here: New Bug Report

1 Like

Unfortunately, I have not been granted the ability to access the Studio Bugs category. As such, I am forced to report on here, as I believe the bugs are related. :pensive:

Please DM me directly about this issue with a video of what occurs. Thanks!

1 Like

Experiencing this (or a related) crash, crashes any time I try to open the insert object menu, also seems to crash when opening studio by clicking the shortcut, The ‘whats new’ pop-up shows up and instantly crashes studio. I’ve tried reinstalling studio, the fixes that seemed to work for people prior such as changing to vulkan didn’t fix anything, with any option for rendering the crash just happens instantly, unlike with OP it doesn’t freeze but rather just closes the application instantly.
Figured I’d just add some information
OS: Win10 64bit
CPU: Ryzen 9 3900X
GPU: RX 5700 XT
GPU Drivers:
Two monitors
Roblox Studio Version 0.546.0.5460523 (64bit)

1 Like

I fixed my issue by Reinstalling Windows 11, Before i had this issue, but when i Reinstalled it, i had no issues after that.

OS: Windows 11
CPU: Intel(R) Core™ i5-10300H CPU @ 2.50GHz
GPU Nvidia GeForce GTX 1650 Ti
On a Laptop

This may not work on everybody though, Its a bit unusual to do but I was having issues on the OS so i tried Uninstalling it, and Reinstalling it

@hunterk1241 Changing the Graphics to Vulkan isn’t a very good idea as it can cause performance issues while testing that are not usually there on other graphics, it may just be me but Vulkan isn’t very good as I have no issues on any other Graphics but Vulkan.

1 Like

With me, Vulkan was the best and worked just as good as Direct3D11; however it runs differently for different devices