Studio Disconnecting

The issue isn’t occurring anymore.

1 Like

If I may ask, did you do anything in specific, or did it just go away on it’s own?


I’m still having this issue. Did studio update for you, or did you make any particular changes?

1 Like

Thank you for reporting this @FederalLaw

We are aware of a potential disconnect scenario in large places (especially those with unions or large terrains) that should happen exactly 6 minutes into opening a session. We’ve been trying to find a concrete repro case. Can you try again and time exactly how long before the disconnect happens? Also would you be willing to share your network stats (e.g. via something like

Feel free to reply to me in a DM instead of this thread.

1 Like

@APaperDeveloper is the issue you are experiencing follow the same pattern as what OP reported? If so, would you be willing to share a screenshot of the disconnect dialog such that we can investigate further. Thanks in advance.

1 Like

The issue I am experiencing has the same pattern. It only occurs with team create on, but it also occurs in actual experiences published to the Roblox platform. When I attempt to load my place with team create enabled in studio, I get this error message:


When I attempt to join the place that crashes in the actual Roblox client, I get this error message (note that I have had other users attempt to join both the team create and the test server on the actual Roblox client):


I also made a full bug report about this about a month ago, although it is incomplete information-wise. It does include a private crash report file from one of the crashes and my system information: Roblox Studio arbitrarily loses connection on one specific place

1 Like

Thanks for the additional info @APaperDeveloper and sorry that you’re running into this. We’ll keep investigating. This is quite helpful for us as we have a solid repro case for a disconnect issues and improving our connectivity is a high priority for us.

A couple more questions:

Before this issue started happening, where there any noteworthy operations you made? e.g. genarting large terrain, making large unions, importing a lot of parts, plugins, etc?

Have you tried saving your place to a new place and publishing that place? Does that cause the same issue? Or is it not possible for you to open the place at all to make a save due to the disconnect issue?


No worries, I’m just glad to see it actually getting some attention.

I have started adding a substantial amount of parts, but it isn’t any absurd amount. It started crashing after adding about 2,000 more, from originally having 7,500.

I have tried publishing to a new place, it still crashes. The disconnect issue does not happen without team create enabled, so for testing purposes I have simply turned it off. Again, this is not a solution though because it crashes in actual Roblox experiences.

Edit: Figured I should mention: No major unions, terrain changes, or plugins have been added. I have added quite a few animation controllers though, but the game still crashes even with the animated objects anchored and not being animated, so I doubt thats the issue.

1 Like

If you don’t mind sharing, what is the roblox place file size when you do save this locally?

1 Like

Sure. I have a version from before I started developing this update, which is 3.29MB. The version with the update in it is 25.2MB. I’m actually quite surprised at the file size difference, I haven’t added anything close to seven more of the original game’s worth of terrain, parts, and scripts.

Edit: 99% of the rest of the game dosn’t use meshes, but this update has quite a few. Once I get the chance, I’ll temporarily delete them to see if thats whats causing the large file size increase, if that is needed.

1 Like

I’m having the same issue on a large part count studio I’m working on.

The issue for me seems to be whenever the studio saves or runs auto-recovery, during which the screen goes gray and then I get disconnected from the team create. I’ve attempted to disable auto-recovery but to no avail (it still runs regardless), furthermore it will disconnect even when manually saving, preventing me from working. It seems that users are disconnected locally whenever they try to save the studio, instead of one person saving and disconnecting everyone at once.

This did begin after I imported a new area of the game with a high part count, however I was actually able to save it after importing, and studio only started disconnecting a couple hours after this change was made. The studio has had a higher part count and file size previously, so I doubt that this is the issue. Additionally, my ethernet speeds are strong (around 500mpbs) and I’ve got a decently powerful PC.

An interesting piece of information is the file size of this studio. Currently it sits around 74mb, however the reason I do not believe this is the issue is because back around July the file size was upwards of 130mb. During this time we actually were not able to save, Roblox would continuously spit out saving errors, however around 120mb was fine.

Not sure what to do, been about 24 hours and I’m trying to get an update out today. Unfortunately I think its an issue with Roblox’s servers, as they have seemed exceptionally slow the past few days. Regardless, I can provide more information if needed.


I’m having the exact same issue. I’ve sent in all of the info requested to Roblox staff, so all we can do is wait.


I had gotten something similar, I was building and got disconnected with

1 Like

Seems like turning off Team Create has given me a temporary solution. Luckily since this studio is tied to a group it allows everyone to continue working on it, albeit one at a time. Certainly not a fun solution, but it can get the job done for now.

Hoping roblox can get a fix for this as it seems Team Create is a bottleneck.

It fixed itself on its own luckily.

1 Like

When the issue was occurring, it would happen only when I either did “save to roblox”, “publish to roblox”, or an autosave happened, and only in team create.

Here are my network stats.

Me & my friend are having the exact same issue - is there any known fix to this as we cannot seem to do anything on our project?

It has started happening to me a few hours ago for no apparent reason too. I was using Studio normally for the entire day today until it started randomly disconnecting me. Every time I try to open Studio it works fine only for a few minutes and then it disconnects me again with a message showing either “Roblox has shut down this server for maintenance” or “connection lost please reconnect”.

The place’s size indeed isn’t small, the auto recovery file’s size is ~95 MB. My internet connection is decent (180/20 mbps and 4 ms ping).

Disabling Team Create is unfortunately not a solution for me. Barely anything is saved even if I manage to do something in these 4-5 minutes of being able to access the place.

@dotstha are you still running into that issue? In particular, have you seen “Roblox has shut down this server for maintenance” disconnect message again recently?

It seems to be working properly now, at least it has been for the last week. I haven’t seen that specific disconnection message in the past week either. Thank you!