Studio Pseudo Test Server breaks

It started happening in the last half hour. It says this on the server:

And this on the client.

I took this pictures from a totally empty game, but I could reproduce in all the games I tried, including ones synced with the Roblox site and not synced.

It also said this on the studio baseplate file I opened (but my internet is running well right now):

I uploaded the place file to roblox and could play it fine.

I am attempting to try on my iMac instead of my laptop, but it won’t even open up the server :confused:


I am testing on a blank baseplate again. When I try to publish to the game website now it reads:

Update: Now on my iMac the server boots with no issue but the client pends for ages before crashing.

I get this quite frequently actually, it can be fixed by running this on terminal:
sudo lsof -i :53640
Then enter your password if prompted
This will show you a list of processes using port 53640
Then take the PID number in the list and use it in this command:
sudo kill -9 PID

I think what happens is the server process fails for what ever reason, and fails to close itself, which is why you can’t start another server.


So on my iMac I got a list of things using that PID number, and killed them, that seemed to work. I went to test another psuedo server, and it booted the server like before, but again the client failed. And now when I run that cmd you gave me again, it shows even more D:

Hmm, odd. Basically the list for port 53640 needs to be empty before starting a server. Maybe after killing the processes check again to see if there are processes running on port 53640.

1 Like

ya i did that twice, and there weren’t any.

This might’ve broken it for Mac idk.

Maybe an update broke it, I would test now, but I’m on vacation atm, and the internet out here is shot.

1 Like

I tried this on my laptop and it worked, but not my desktop. Guess I’ll just have to use my laptop for the time being :c

Huge thanks though

Might not want to mark solution yet, because this is definitely still a problem with Studio. The test server fails to open properly about 50% of the time, and then the port becomes completely glitched (preventing any subsequent test servers from starting) until you manually clear the port, either by restarting your computer or using the very helpful process posted by @Baumz.


ya i guess. Still can’t get studio to run on my iMac properly either.

This issue is still happening. Bless up Baumz for his solution lol.

Stilllllll happening.

Can you try this command in your terminal and tell us the results?

sudo lsof -i :53640

Also, what ISP do you have?

When I do this, and I do it frequently because it often breaks, I get a list of PIDs, and then I kill them using the command Baumz. I get the problem at home and when I’m at school (I’m at a boarding school). They both use BT internet.

I’ll post the output specifically when I have this issue again.

This is what prints out when I enter what you told me to:

Last login: Tue Oct 17 13:55:22 on console
Nicolass-iMac:~ NicolasMarkham$ sudo lsof -i :53640
RobloxStu 12669 NicolasMarkham 185u IPv4 0xce1924be2c5dc11d 0t0 UDP localhost:53640
RobloxStu 12669 NicolasMarkham 186u IPv4 0xce1924be2c5d9b1d 0t0 UDP
RobloxStu 12669 NicolasMarkham 187u IPv4 0xce1924be2c5dc37d 0t0 UDP
Nicolass-iMac:~ NicolasMarkham$

I am looking into this issue, can you tell me how studio exited the last time it successful started?

1 Like

Unsure quite what you mean. In the times before it breaks, I seemed to notice that all three (1 server, 2 clients) seemed to snap shut rather than the client, client, server order it used to be, however I haven’t had this problem much recently, so I can’t really say how accurate these recollections are.

Sorry I couldn’t be of more use :confused: , but thanks for looking into it!

This is still a thing

still a thing