Studio things not working

My studio hasn’t been working ever since 2 days ago, I can’t open game settings, select, rotate, move, or do anything that much. My mouse in studio appears to look like the in-game mouse, and when I’m in testing mode my toolbox works fine as well as the move tools etc.
I’ve already tried restarting studio, reinstalling twice, and restarting my PC several times.
Any suggestions?

5 Likes

While you have said you have reinstalled studio, have you uninstalled Roblox Studio fully?

I’ve had this problem before and it’s quite annoying to say the least, however, after a lot of experimentation, I realized that while you may delete the studio on your desktop and/or taskbar, this is not completely uninstalled, which can let those bugs still exist.

Uninstall with Windows 10

  • First step should be to go and open up the Control Panel.
  • Open Programs and Features.
  • Scroll until you find Roblox Studio.
  • Right-click on Roblox Studio and click Uninstall.
  • Afterwards, follow additional steps if your computer prompts.

If this does not fix the problem, you could try hard-uninstalling both Roblox and Roblox Studio and see if that fixes the problem. If not, then you will need to find a different sollution. This is just one I know.

I do not know how to hard-uninstall Roblox Studio on other devices, so you may need to look around if you aren’t using Windows 10.

1 Like

That did not work for me.

Do you have any other suggestions?

Thanks for the advice though

Close & open your studio until you see the normal mouse. Everyone has this bug. Sadly no one can post it in the bug category which is a big rip.

1 Like

I did the same thing, did not work

2 Likes

Then you should try @Avtixe’s suggestion. While I haven’t been getting problems with Studio, I have been noticing that some people are. If you do come across another problem in the future, I’d recommend hard-uninstalling.
As for now, I wish you luck in fixing your problem.

1 Like

what os do you even use
Mac or Windows
if mac then what version
if windows then eee

1 Like

Re-installing studio will have no effect on your problem. This is such a huge bug which sadly cannot be fixed by us users. I’m not hating or nothing but roblox staff really need to check all of these posts about studio bug problems… A-lot of users are facing this problem and are worried about it. The best solution to fix this for temporarily duration is just close studio and re-open it until you see the normal studio mouse.

I’ve been having this problem since last week. Whenever I leave studio after finishing my work, it gets back to that broken studio bug thing & then I have to open and close studio until I see the it getting normal.

Also, don’t worry. Your not the only one who is facing this problem. A-lot of developers are having this same exact prob including me.

1 Like

I use the Windows as my platform.

1 Like

Thank you for the help, I will definitely try @avtixe’s suggestion shortly.

2 Likes

incase uninstall doesn’t remove all the files go to C:\Users\ur pc\AppData\Local\Roblox or C:\Users\ur pc\AppData\Local and find the Roblox folder and del it
then try to reinstall Roblox or get a fresh new installer since old installers r wack

1 Like

I can promise you uninstalling studio will not fix this problem since a huge portion of developers are experiencing this same exact issue. This is a bug happening with studio for god knows what reason.

1 Like

welp i havent used studio in a while since i do my animations off site so :man_shrugging:

1 Like

that happened to me too. when i open a big game the mouse just wont select or move things.
I found a way to get it back to work but you have to do it everytime you open roblox studio,So i open a small place or empty one and select any object then i go back to the other game and the mouse work again as supposed to do. This bug still happens to me ,i have no idea what is the reason but this is the way i fix it.
Hope this helped you!!

1 Like

This also happened to me, and it is due to roblox updating the tools, first go to plugins and enable a plugin leave it enabled, but make sure it’s one that wasn’t already enabled, then exit studio click save and re-enter studio.

I hope this helps!

1 Like

Like I mentioned this happened to me too but the way I put it fix’s it completely and the way you’re doing it only fix’s it the first time you open studio and when you close it the bug happens again, maybe try follow my steps if you wish it may help!

1 Like

Your post is really similar of the mine


The best solution what I found is on 1st post

Try pressing file>close file>find your game then try, you will have to do it everytime you close studio.

4 Likes

Thank you so much! This really helped and it worked.

1 Like