Super laggy script editor on Mac - fixed


#42

Are you by any chance using a 2016+ MBP?


#43

Yes sir


#44

@alexnewtron had this exact same issue although I don’t know how/if he solved it. I pinged him but he isn’t online atm so I’ll drop a mention here.


#45

The only solutions for now are:

  1. Use a 1080p monitor. This issue seems to be related to the DPI of the Macbook Pro built-in retina display, or any monitor with a high enough DPI. So 1080p is recommended.

  2. Lower the scaling of your Built-in retina display. Under macOS Settings -> Display -> Resolution: Scaled
    This solution isn’t perfect though, and there is still some lag but not as much.

or 3. Change your Color Profile


Known issue for Macbooks running macOS 10.12 (Sierra) and higher
#46

Please see this thread:


#47

unparenting works for me, thank you
at least it’s now usable
Still would be nice if ROBLOX actually fixed this…


#48

Its been nearly 6 months :no_mouth:


High Sierra Issues Makes Studio Unusable
#49

This was a tough problem to solve and went through multiple rounds of discussion within the company. We finally think we fixed some issues by backporting a patch from Qt 5.9. This will be going out early next year.


Team Create silently disconnected me for 2 days and erased my work
#50

The fix for this should be out. Please let us know in this thread (Known issue for Macbooks running macOS 10.12 (Sierra) and higher) if you continue to have issues.


#51

It appear to have remerged…
Script editor is super laggy again…


#52

Oh no… :scream:

I will re-open the ticket internally.


#53

It appears the old work around of changing the colour profile still works.


#54

Please make sure you’re running the latest Studio (0.345+) as last Wednesday we’ve deployed a fix for this exact issue. If you’re on the latest, can you please confirm you’re still able to repro it?


#55

Works like a charm now


#56

Good to hear that. The issue was likely caused by the recent OS X update pushed by Apple. We’ve noticed that and resolved it promptly.


#57

My script editor has become incredibly laggy with this piece of code in a modulescript:

function CreateLine()
	local Line = Instance.new("Frame")
	Line.BackgroundColor3 = Color3.fromRGB(0,0,0)
	
end

return CreateLine

This starts to become laggy when typing on line 4.
The wierd thing is that I’m on windows 10 64 bit.
Dark theme is also enabled if that helps.


#58

This is a mac specific thread and the issue was fixed. I’ll update the title to reflect that.


#59

I know, I was stating the fact that I was experiencing the laggy editor on a Windows machine which I thought was unusual, thats why I posted it here.


#60

Please create a new bug report in that case, as it is a different issue.


#61

Tried it out on a similar machine, but don’t see any issues. First of all, I agree with EchoRepear, this is a different problem. Second it may be specific to your machine or your place. Please try it out on a different PC, different place. If the problem reproduces post a bug, PM me your place.