Team Create Bugs. Post 'em Here!

studio
teamcreate

#105

Thanks for reporting this, we’ll check it out.


#106

In the team creates I’ve been invited to recently, the other people I am working with are loaded in, and I can see what they are working on and the changes they are making, but I cannot see their orbs moving.

They are locked in place where they spawn into the team create.

Here’s a picture to see; https://gyazo.com/19e8cc89aa28d54bf6840864ead073b3


#107

Sounds like the problem reported by Lightning_Splash. I think this feature just got broken. Going to fix it.


#108

Here’s one that just started happening:

  1. Open a team create place, and have another person also join you.
  2. Start a “Local Server” test, any number of players
  3. Clean up.
  4. Start a “Local Server” test --> Studio crashes

Issue does not occur if you start a “Team Server” test, or if you start a local server on a local place file or uploaded file that is not a team create place. Issue also does not happen if you are alone in the team create server.


#109

Thank you for reporting this issue. We’re planning to release new Play Solo that will eliminate the need of start server/client feature. We will make sure it works fine with Team Create.


#110

Recently, I was working with a few friends in Team Create. After a while, it seems I got disconnected without any prior warning. None of my changes would replicate, and even restarting studio wouldn’t fix it. It’d just open up studio while retaining the property of unable to save my changes. I’m not sure how to replicate, as it happened randomly. I ended up having to turn team create off to do any work in the game.


#111

Hi, Starception,
It sounds to be a weird issue. Recently we fixed a few bugs to make sure Studio handles team-create disconnection correctly. And after reconnecting to team create server or restarting Studio, the game should work fine again. We could not reproduce the issue in your post. Could you provide us the studio log files when the issue happened?
Thanks a lot for your helps!


#112

Sure. Could you tell me where to find them?


#113

Windows:

  • Put %LOCALAPPDATA%\Roblox\log into the file explorer address bar and zip the content
  • Put %localappdata%\Local\Roblox\logs\archive into the file explorer address bar and zip the content

Mac:

  • Open Finder
  • Open “Go” menu
  • Select “Go to folder” and post ~/Library/Logs/Roblox there, archive the content

#114

A developer that I am working on a project with is having some bugs/usability issues with team create. I don’t want the feedback to slip through the cracks so I am going to post 'em here.

“The greatest issue I’m experiencing with team create right now is the studio shutting down when my computer goes into sleep mode; I simply go to the restroom and then I lose the progress I made with my code :neutral_face:. The rest are smaller issues like not being able to cut and paste objects when you have descendant scripts open.”


#115

Hi, VitalWinter,

Thank you so much for your report. I am wondering if you could provide log file when the problem occurs?
And could you provide more details about “studio shutting down” in your report? For instance, Studio quit? Studio crash? Team Create disconnected?

Besides, if your computer goes to sleep and you are modifying script in team create session, your team create may be disconnected due to timeout. And the script recovery is designed for such case. You can always find your local change not submitting to the team create server.


#116

Hi, VitalWinter,

Just rechecked the issue, I think I got better understanding about it:-)

1: For team-create game, Studio is expected to be always online, meaning to be connected with the TeamCreate server. Once the disconnection is detected, Studio closes the game and tries to re-connect. You know, windows goes to sleep may cause the disconnection from TeamCreate server, then I think “the studio shutting down” in your post means the game being closed.
2: Once disconnected from team create server, Studio cannot publish change any more.
3: To improve above issue, Studio has script recovery mechanism, once the game is opened again, hopefully it will reopen the previously opened scripts, automatically acquires lock if no one else locks it. Then load the local backup ones.

Recently, we fixed some bugs related to TeamCreate not handling disconnection correctly, and some other cases which may cause user change loss. Besides, we also fixed some issue about script recovery logic for the team create. Could you please try again to see any problem still there?

Thanks a lot for your helpful report, helping analyzing and improve Roblox Studio:-)


#117

A developer I’m working with asked me to post this teamcreate bug he is experiencing. Here are his words:

For the last 2 days, All my Team Create places, including my group’s main place that has team create enabled isn’t allowing anybody to load into the game(play it) and I am also unable to open it in studio at all. When I try opening it in Studio I get this same error : http://prntscr.com/kpgild

I’d like to know if anyone has ever found a fix to this? Because Roblox Staff itself isn’t answering my support requests.

One of the affected place that you can notice this at: https://www.roblox.com/games/1104489381/ToW-Kaliningrad-Russia-2019


#118

Hi, ColonelGraff,

Could you forward me the log file and dump file when that happens without closing Studio? Thanks a lot:-)
The way to generate full dump is as below:
https://support.microsoft.com/en-us/help/931673/how-to-create-a-user-mode-process-dump-file-in-windows

Thanks a lot for your kind helps:-)


#119

Hi, ColonelGraff,

It seems that the team create loading timeout. Please check whether there is below entry in the log file when error occurs:-)
“Timeout on connect, unable to initialize Team Create server.”


#120

Hi @lll_xyz and @DreamingMind,

Recently I ran into a bug where team create completely lost connection to the server for both my friend and me. When we were both trying to reconnect, it kept failing to reconnect for some reason. Eventually after a few attempts it was able to successfully reconnect. It also appears none of our changes were lost meaning the server still saved the place when we both lost connection.

Ultimately, the two underlying issues here are that it lost connection for both of us and then it had trouble automatically reconnecting for a bit.


#121

Hi, UnderMyWheel,

Thanks a lot for your report. You know, the connection to TeamCreate is a complicated process, involving Studio, Web Coordinator and TeamCreate GameServer. Based on your description, it seems more related to GameServer & Web side.

For instance, Game Server crashes or restarts somehow, and all your team members lose connection. Then Web may take some time to detect it by timeout, and the reconnect from Studio triggers Web to allocate another GameServer, which also take some time to start & grabbing your published game from Web, then Studio is ready to be working with it.

Since it is rather a complicated processing, we can consider adding more log info in Studio, to see if it help better figure out which step may cause problem:-)

And if possible, could you please share the log file & dump file when the problem occurs, which may help analyzing? Thanks a lot!


#122

The following occurs when I press File > Publish to Roblox in Team Create:
team%20create%20error
It claims to have published successfully as usual, however, there is a message in between indicating there was an error. If I close and rejoin the Team Create, the changes are lost.
Please fix this upload error as well as the misleading success message. Thanks.


#123

This was reported in this thread:
https://devforum.roblox.com/t/widespread-publishing-error-affecting-most-games/179396

It has since been fixed


#124