Technical Difficulties - Error 529

This bug recently surfaced up. What’s going on here? This completely stops me from joining any games. The servers that are affected are deployed, pre-existing ones aren’t affected.

First occurence: 11:30 CEST
Frequency: Consistent, but not always

Additional related issues:

  • TeleportService cease to function correctly; Error 769
  • Team Creates is also down
  • Websites sometimes aren’t loading(region-based?)

Same thing happening here! I don’t know why this is happening, re-installing doesn’t seem to help…

1 Like

That started happening to me also, any games I tried to join, I get that error, what’s going on?

1 Like

This seems to also happen to me.

Seems to be affecting everyone else, can confirm as players in a game i develop for are encountering the same issue.

Tried to repro this and it also occurs on mobile and Xbox.
Could not get a screenshot from Xbox, and I’m just taking word from a relative who’s trying to access a game from their console.



I rejoined a bunch of private servers multiple times and did NOT recieve the error, but instead received longer than usual loading times (up to 30 seconds longer than average for my device), did a Speed Test and all came back clear, so it doesn’t seem to be a WiFi situation.

This doesn’t seem to be removing players from servers they were already in before the initial occurrence.

1 Like

It doesn’t seem like everyone’s encountering the issue, since there are still thousands of concurrent players on the front page.

As I have previously mentioned: The reproduction is not always, it is consistently reproducable in certain conditions and I cannot identify under what circumstances the servers would allow you in and vice versa.

Try this for reference:

1 Like

It only affect to newer player who tries to join, concurrent players aren’t affected yet.


For me, every game is working fine

I tried to join Deathrun and it worked

Seems to be certain games on certain device’s, games I can’t join on mobile others in the house can access on the computer.

Unsure does this relate, but teleport doesn’t seem to work as well.


Looking at doesn’t give any info on this particular issue. The latest one dates back 8 days ago.


Pretty sure the status site is manually operated by staff, not automated. Service disruptions are not reported automatically unless a staff created a new event there

1 Like

Yeah, this has been happening to me for the past couple hours.

That looks to be related since your teleporting to another place.

Adding onto this, I believe the team creates are all down as well, because I continue receiving this error.


I have this problem too, thought it was only me as some people are still playing games

Can confirm. This also happened to me.


I’ve had this as well, as people have said, this not only affects games, but ALL team create places themselves, you crash once you enable team create or join a team create place before this bug existed.