Terrible mouse sensitivity bugs within Studio

Currently, and randomly, my mouse has begun to have several problems within studio that it has never had before. This appears to be the result of some recent update from this or last month…?

The main problem is the mouse becomes extremely sensitive, making it near impossible and also very annoying to rotate.
This bug will also make the mouse ‘jumpy,’ snapping the camera after every few ms of dragging.

This is a studio only bug as I have tested this in-game and the camera works just fine.
Modifying the Hardware Mouse attribute in studio has done nothing useful and neither has disabling the Enhance Cursor Precision option in Windows.
It is also of note that my laptop’s trackpad is tracked just fine, only my mouse is having issues.
This problem mainly affects the ability of using the Studio camera.
Although this does also occur (for whatever reason) when using Play Solo and etc, custom camera implementations are handling the mouse just fine (so the input from UIS appears to be unaffected).

What’s your sensitivity on? Maybe that could mean something?


The sensitivity setting for Roblox is the same as the one in Roblox Studio.
My friends have been reporting the opposite happening for them where their mouse sensitivity seems to have been lowered


I also have the same issue my camera in studio kept quickly snap to a different direction and it is very annoying. I’m gonna start having fade with this software if they dont fix studio >:c


Can confirm. Use arrow keys as a temporary fix for now, but it won’t work in the long run.


I had this in the past when using a Cloud PC stream service like Parsec & Shadow PC.

Parsec never got solved.
Shadow PC solved by going into fullscreen mode.

Might be related with screen size or such, because the hosted PC has technically a different screen output than the client PC. This can indicate a conflict in screen sizes, and I would recommend you to check your screen configuration.


Any planned updates or ways to fix this yourself? This bug is seriously annoying.

Edit: this bug appears to only happen when in windowed mode while the window is not maximized. Maximizing your window will fix it.


I am experiencing this issue as well and it is making it very difficult to make any precise camera movements. As others have noted, when attempting to move my camera around by holding right click with my mouse, my mouse cursor will appear “jumpy” and my camera will snap to random unintended angles.

Expected behavior:

When moving the camera in studio, it should appear to be smooth and completely connected to the movements made by your actual mouse.

Current behavior:

When moving the camera in studio, the mouse is jittery, jumpy, and periodically snaps around to different angles.

Repro steps:

  1. Open a place in studio.
    Any place will demonstrate the mouse jitter bug, being that the mouse is not visibly connected to the mouse movements made by my actual mouse. However, the camera snapping bug is more visible in a place with a lot of parts (mine has 17k). I can provide my place file to an engineer that asks.
  2. Hold right click and move mouse around.
  3. See current behavior.

Additional information:

  1. All of my studio plugins are disabled.
  2. I have a Razer Mamba Elite mouse.
  3. I quit Razer Synapse to see if that was relevant, it didn’t seem to be.
  4. I toggled “Enhance pointer precision” on (it was off) in the Windows mouse properties menu, which did nothing.
  5. I uninstalled and reinstalled studio, which did nothing.

System information:

  • OS: Windows 10
  • CPU: Intel i7-4790k @ 4.0.GHz
  • GPU: NVIDIA GeForce GTX 1080
  • RAM: 16 GB

Videos demonstrating bug:

Mouse jitter and jumpiness:

Camera randomly snapping to unintended angles:

I lowered my sensitivity to 0.2 to exaggerate the issue to make it more visible, since the camera snapping seen in this video should not be possible to occur at this sensitivity level. This bug also occurs outside of play solo as can be seen in the previous video.


I have the same, could anyone help?


I’ve had this issue once. I personally fixed it by changing the polling rate on my mouse to a lower value. I can’t confirm it will work for others though of course.


I had this exact same issue and it was super annoying, took me weeks to figure out but its quite simple

Depending on what mouse you have you want to open the associated software. You want to look around for a setting called mouse polling rate and try lowering it to the lowest value possible and pressing apply. If this works increase it abit and try again it might also not work untill you restart your pc so try that aswell.

1 Like

Sadly none of the methods others mentioned worked. Only thing that works is lowering my DPI to unusable numbers like 200 to get the mouse sensitivity I used to have in Studio. Also, I only have this issue since the latest update. It’s annoying cause Studio is literally unusable now.


What is your mouse polling or reporting rate?
I have the same issue with my Logitech G502 Lightspeed but fixed it by just turning down the reporting rate in the G Hub software.
Aka just lower polling rate.

Edit: Just realized this is from 3 years ago. Uhh ill still leave my comment here for anyone else

I also have the G502 and lowered the polling rate on the software which seems to have fixed majority of my problems for now thanks! Despite this post being from 3yrs ago, I notice people still get this bug on a reoccurring basis sadly :frowning:

Turned down reporting rate in G Hub, but a fix should be implemented for this.
I have a G305.

I am still heavily impacted by this issue as of 7/22/22.

1 Like

I’ve been experiencing this same issue for months.
It just randomly appears and disappears for days.

GPU: RX 590 Nitro
CPU: Ryzen 7 2700x
RAM: 16GB 3200mhz
Screens: 32" 2k 144hz + 27" TV turned monitor

I am using a G502 Hero mouse with mouse polling rate set to 1000

This issue keeps appearing and disappearing every couple of days

^^ Spikes = Camera snapping

sorry about the bump, but I think this needs to be addressed again. this bug is now being impacted INGAME, making roblox basically unplayable. sensitivity randomly becomes high and low, sometimes jittery. I hope ROBLOX fixes this soon, this is soon becoming a critical bug.

1 Like

Yeah had this issue for 1 year+ before I changed my GPU
There are 2 ways to fix it yourself until roblox addresses this issue (which will probably not be any time soon):

  1. Turn down your mouse polling rate (I had mine at 1000, turned it down to 500 and no more issues)
  2. Upgrade your GPU (ever since I upgraded from RX590 to a RX 6750XT I had no more issues like these except the time i was running like 8 studio instances, that’s the only time I saw this bug appearing again)

I have this issue too. Being in roblox studio and a roblox game at the same time screws with the mouse sens in the engine. The only fix I know is closing both and opening one at a time. I don’t know how to reproduce the issue though, it doesn’t happen all the time. I usually up the sensitivty in each playtest in studio to band-aid fix this.

Not going to degrade my mouse preformace so roblox works.

Not going to spend hours and weeks of hard work getting the money for a better GPU when roblox could spend a day or two to fix this.

1 Like