The Favorite Button for Games is not Working

Bug Information

The title is self explanatory. The favorite button for games does not seem to be working at the moment.

Previously, I would expect the favorite button to add a game to my favorite games list.

The bug could have been caused by the latest update to the website (new icons, etc.)

Notable Observation

Browser Information

Browser: Google Chrome
Version: 79.0.3945.130 (Official Build) (64-bit)

Additional Information

I am not using a VPN at the moment

1 Like

Can’t seem to reproduce on any game page, I’m on the same version of Chrome as you currently. Out of curiosity can you disable your extensions temporarily to see if it still occurs?

Just tested on igcognito with no extensions on another account. I can still reproduce the bug.

Edit:
I will try to reproduce on my other computer.

Update:
I can reproduce on my other computer

1 Like

Can you load up a game page, press CTRL + LSHIFT + I to open up the Developer Tools, and go to ‘Network’ shown here?

When you have this open, click the Favourite button on a game and see if the request named toggle is going through properly (indicated by a Status 200 code).

1 Like

I got this error:
image

This error seems to be caused by a lot of requests being sent at once (i.e adding something to favourites quickly). I can reproduce this behaviour by clicking the favourite button again and again, however after a certain period of time I am allowed to favourite items again.

Update on Bug

  • Clearing Browser Cache and Cookies did not resolve issue
  • Waiting at least 10 minutes did not resolve issue
  • Using a VPN did not resolve issue
  • Bug can be reproduced on another device and on another account

Additional Information

Error Code received after pressing favorite button:
image

Please note that I have not favorited a game for like 5 years, so a cool down seems like unintended behavior.

Have you tried to reproduce this bug on different games, preferably one you have played, other than Adopt Me?

Update on Bug

  • Using another browser other than Google Chrome, I am still able to reproduce
  • Using my phone’s cellular instead of my home’s network seems to have fixed the issue, however it
    would be inconvenient for me to use my cellular when I want to favorite a game…
  • I have not in any way modified my network configuration/setup recently

I can’t seem to reproduce this bug.

The bug is specific to certain people or only me. My network seems to be blacklisted from being able to favorite games.

4 Likes

Update

The bug still hasn’t been resolved as of today. All previous observations are still occuring.

Works good for me.

Is it only on one game or on every game?

I also experienced this issue. The problem has solved itself at my computer, but I am not sure how.

By the way, I am pretty sure that your internet network isn’t related to this issue.

It’s specific to my network only. All games cannot be favorited.

I’m pretty sure it’s my network since my other computers at home cannot favorite as well. However I can favorite games on the mobile app.

Weird. I tried it on two different devices on the same network. At the one device (Windows 10) it did not work and on my other device (Chromebook) it worked.
Now it does work on both devices by the way.

Does your network that you are using have any active blockages?

That’s where I’m confused. I have not modified my network in any way before I noticed the issue. It just happened.

I have modified my network like 5 months ago, but the favorite button was still working.

Very weird. Like mentioned before, I experienced this issue too and it fixed itself. I did not change anything to my computer, browser, internet settings and so on.

I am not sure where the problem is but I hope that the developers of Roblox are able to address the issue and fix it.

The “429” indicates that you are being throttled because too many favoriting and unfavoriting requests have been coming from your account, but this shouldn’t trigger unless you try to favorite or unfavorite more than 1000 games in a minute OR your IP is blacklisted for some reason. We will look into whether something else may be going wrong that might cause this.