UI Stroke "Contextual" mode: Broken

Reproduction Steps
Any text label I am currently using in my game with the “UIStroke” object applied and the “ApplyStrokeMode” property set to “Contextual” makes the text completely transparent no matter what properties I change.

Expected Behavior
The text never went transparent before when trying to add a stroke to any text labels. It worked perfectly until about 30 minutes ago when I opened studio and all text in my game that was using UIStroke has become transparent (Other than the stroke)

What should happen is the text stays visible while the UIStroke does the same as before.

Actual Behavior

UIStroke: Disabled


image
image

UIStroke (With Contextual ApplyStrokeMode): Enabled


image
image

Workaround
Someone probably just made a typo somewhere. Idk

Issue Area: Studio
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2021-07-21 15:07:00 (-04:00)

16 Likes

I can confirm this is happening to me as well.

1 Like

Kinda annoying when u use a lot of them :confused: Hope they get it fixed soon!

Also broken for me for everything with a UIStroke text is invisible.

1 Like

The same thing is happening to me too.

image The text is completely invisible, and only becomes visible once UIStroke is removed

2 Likes

Can confirm still happening today

image

Also can confirm, here is a GIF of it:

Caught this while streaming development lolol

2 Likes

I do hope this issue does get resolved soon as well considering how much I’ve used them so far.
Here is a few cases where it’s affected my Ui’s!
image

It really has made a mess of several menus, I assume this will be fixed soon anyway.
This post was made just to confirm this indeed is happening consistantly.

This is also happening to me.

With:
image

Without:
image

UIStroke is still in beta and has not released yet, they have been experiencing a lot of bugs so they probably temporarily disabled the FFlag. See UIStroke - Studio Beta (UPDATE: re-enabled) - #210 by Tiffblocks

1 Like

Hi, thanks for the report! I wasn’t able to reproduce this on my side, is it still occuring on yours?

1 Like

Still seems to be occurring on all UIStroke’s, but a fix is being worked on

yes! Hasn’t been fixed since I made this post

4 Likes

It has now been fixed! (Well to what I know with my experiences with it now.)

UIStroke is now live:
https://developer.roblox.com/en-us/articles/applying-strokes

Let us know if you have any further issues.

2 Likes