Unable to Open Experiences and Places in Experiences

Reproduction Steps
I get an error message almost every time I open my Farming among Friends experience (any other random experiences) through Studio. When I can open the experience, I am unable to open any places that are part of the experience. No error message, studio opens, loads for a second, and closes when trying to open another place.

System Information:
Windows 10
Roblox Studio Version 0.519.0.5190432 (64bit)
Intel i7-6700K, 32GB RAM, RTX 2080

All plugins disabled
No beta flags enabled

Expected Behavior
I expect the experience/place to open and studio to not close.

Actual Behavior

When trying to open an experience, I get this error dialog. When I try to open a place as part of an experience, studio attempts loading and just closes out with no messaging.

Issue Area: Studio
Issue Type: Crashing
Impact: Very High
Frequency: Often
Date First Experienced: 2022-03-26 21:03:00 (-04:00)


I have also been affected by this issue and can’t open or join and of my games.


I’ve been experiencing this a lot the past couple days. I get the exact same error message, sometimes if I retry it enough it will open my experience, but none of my meshes, unions or textures load. With experiences it loads me in, but many things remain blank till it eventually crashes. Hope it gets fixed soon.

1 Like

I am also having issues with meshes and textures loading when the experience sometimes manages to load. For example, third try the place finally opened and resulting in a bunch of these errors:

  MeshContentProvider failed to process https://assetdelivery.roblox.com/v1/asset?id=215735235 because Error reading mesh data: unknown version

I have being seeing weird textures like this in game and in studio the last two days as well:

See related bug report:

1 Like

@TheNickmaster21 This place loading error seems to be a slightly different manifestation of the meshes and texture loading issues. Are you still experiencing this issue with place loading specifically, or do you know when you last saw it?

I seem to be able to open the experience and places again but I still get a bunch of MeshContentProvider errors when opening up the places.

Thanks, knowing that the place loading error is resolved is very helpful for getting to the root cause. I’ve posted a workaround for the asset loading issues on the other bug report: Games and studio failing to load - #41 by ramblinwrek