Up-to-date Roblox client tries to use an old API endpoint to authenticate when joining games

Ever since this morning, I have been entirely unable to join games on Roblox. Whenever I press Play to join a game, the client will start up but will silently close shortly after, without launching the game. The startup log shows the following as the last 2 lines:

2021-03-31T01:32:19.815Z,0.815260,2374,6 [FLog::Output] Authentication request URL: https://www.roblox.com/Login/Negotiate.ashx ticket: (hidden)
2021-03-31T01:32:20.374Z,1.374291,2374,6 [FLog::Output] Authentication request failed. status code: 404, error message: HTTP 404 (Not Found).

(Full log available here, although there’s not a whole lot else)
As far as I can tell, https://www.roblox.com/Login/Negotiate.ashx is a fairly old API endpoint, yet I’m running a very recent version of Roblox (0.472.0.419960). I’m not sure why it’s sending requests to an old API endpoint like this, and everything I’ve tried to fix it has not been successful, including:

  • Restarting
  • Reinstalling Roblox (both by uninstalling normally, and by manually deleting the Roblox folder and reinstalling)
  • Clearing my browser’s cookies and logging back in
  • Using an entirely different browser
3 Likes

You should try to reinstall Roblox completely as your launcher should have updated today with a fix for this. The newest version of Roblox is from today when there was an update on both the client and studio. It appears that this deprecated endpoint was finally replaced with the appropriate one from auth.roblox.com. On my computer, I can see that the new endpoint is indeed on the latest version of Roblox. Follow these instructions to completely uninstall Roblox and remove its files.

1 Like

I mentioned it on my post but I’ve already tried entirely reinstalling Roblox - both by uninstalling it through Apps & features and by deleting the Roblox folder in AppData/Local, but the issue still occurs after a fresh reinstall. I’m also sure the version it’s launching is in that path as I’ve checked the process location in Task Manager, so I’m fairly sure it’s not launching any other version hidden around in my system. This is the thing that was confusing me, why reinstalling seemingly hasn’t fixed the API issue.

same thing has been happening to me yesterday, havent joined many games today.
i tried reinstalling many times to no avail, really was a pain not being able to launch roblox.

1 Like

This has been happening to me since Monday.
I’ve tried uninstalling and reinstalling Roblox again and it still doesn’t work. I also deleted all the files to see if it would fix it, but it did not fix the issue.

Edit: I just found out that both versions of Google Chrome are preventing Roblox from launching. I have to use another web browser to be able to launch Roblox. It seems that the problem is on Google’s end.

image

image

I don’t know why but Roblox Studio uses auth.roblox.com as it’s endpoint but the cliend uses the old one. One wierd thing is that the Windows 10 and Mobile releases of roblox don’t have this problem.

This may be or not related to this but when i tried to log into my account in a instance of a google chrome user without a google account, after verifying 2-step verification, i was returned to the login page with no change. For some reason it added a nl=true paramiter.

I tried using Edge version 89.0.774.68, Opera GX version 73.0.3856.424 and Firefox version 87.0. All of them up to date, yet none of them fixed the bug. What browser are you using?

It works for me and I’m using the same version of Edge as you. The only difference is that I had to delete my %temp%\roblox folder recently.

1 Like

This might be a PC or a Roblox problem, but i removed the %temp%\roblox folder, ran Roblox from edge, still broken. Checked logs, same error.

Try deleting %localappdata%\roblox as well. Even when you uninstall it. Roblox still leaves some files behind. If that doesn’t work, then I guess there’s nothing to do on your end.

I have deleted both the %temp%\roblox and %localappdata%\roblox folders. I reinstalled roblox and ran it through edge. Still errors out. I’m done with this.

I’m using the latest version of firefox and it fixed the problem of not being able to join games.

image

The bug seems to be fixed on Chrome.

This has been happening to me ever since FFlagPlaceLauncherAuthenticationUseNewHttpRequest was set to True. A system restart temporarily fixed it, but it has reverted to using the old endpoint again.

1 Like

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

1 Like

If this using old API (Login/Negotiate.ashx) still happening, can you please send us your current log files of :
%USER%\AppData\Local\Temp\RBX-.log as well as %USER%\AppData\Local\Roblox\0.xxx..log ? Thanks!

3 Likes

Not sure about anyone else, but as of yesterday the launcher has started working again for me! I don’t know if a client update fixed it or what but it seems to have fixed itself on my end.

My launcher still keeps using the old API point.

I have no idea where that is located.

Use %localappdata%\Roblox\logs and %localappdata%\Temp as the address path in the file explorer (assuming you’re on Windows)

1 Like

Thank you for telling me where those specific files are located, but I have no idea where to send them at.

1 Like